iPhone iPhone keeps respringing into safe mode

Discussion in 'Jailbreaks and iOS Hacks' started by mattschey, Sep 22, 2013.

  1. mattschey macrumors newbie

    Joined:
    Sep 14, 2013
    #1
    Hey

    My jail broken iPhone 5 6.1.2 running evasion keeps re springing into safe mode. I installed a tweak today called "norespringchirp" and at the same time I updated "flipswitch". This caused my phone to respring into safe mode, so I immediately uninstalled "norespringchirp" and it is still springing me into safe mode. This is the only tweak I have installed in the last few weeks and my phone was running fine up until today. Every time I hit exit safe mode, it just puts me back into safe mode. Also, every once in a while, through a hard reset, it boots up into a "semi normal" state. What I mean by this is that some tweaks are working, but others aren't and everytime I respring, it puts me right back into safe mode.

    I installed crash reporter and this is one of the reports

    Crash log
    http://pastebin.ca/2456957

    Syslog
    http://pastebin.ca/2456960

    Dyld crash log
    http://pastebin.ca/2456963

    Dyld syslog
    http://pastebin.ca/2456965

    Has anyone encountered this before or have a solution for me?

    Thanks
     
  2. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #2
    uninstall flipswitch as well.

    you can disable all JB apps with either SBsettings/more/mobilesubstrate addons or you can use iCleaner pro to do the same, then 1by1 or in batches enable the apps to see which is causing the safe mode
     
  3. eyoungren macrumors P6

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    Phoenix • 85037
    #3
    Oh man! I was thinking of installing NoRespringChirp AND the update to Flipswitch earlier too. But I settled on just the FlipSwitch update as I don't respring plugged in enough to justify another tweak.

    Considering your problem I'm glad I didn't. My update of FlipSwitch was fine though. Do as TriJetHero suggests. If you're good you can try reinstalling FlipSwitch. Maybe something got corrupted/conflicted with what you did at the same time.
     
  4. mattschey thread starter macrumors newbie

    Joined:
    Sep 14, 2013
    #4
    Thanks. I used this method to find the problem. The reason I didn't try this in the first place was because the only addons that I added today, I deleted right away (flipswitch and norespringchirp). So I didn't think it was an addon issue. But I tried this method and ended up finding the issue. It ended up being a tweak called "lock bar pro" which I had been using with no problems for over a month now. I find it strange that it started giving me problems out of no where, but at least the issue is solved. Thanks again.

    Neither of these ended up being the issue. See above.
     
  5. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #5
    may i ask what does norespringchirp actually do? I read the description but don't get what it means
     
  6. BumpyFlatline macrumors 68030

    BumpyFlatline

    Joined:
    Apr 11, 2012
    #6
    Whenever your device is plugged into a power source and you respring, it makes that "charging" sound. This tweak simply disables that sound.

    I imagine its most useful for jailbreak devs who are working on something and constantly respringing their device.
     

Share This Page