iPhone keyboard all exclamation marks - HELP!!

Discussion in 'iPhone Tips, Help and Troubleshooting' started by CharlieBoyCav, Jun 9, 2012.

  1. CharlieBoyCav macrumors newbie

    Joined:
    Jun 9, 2012
    #1
    Hi,

    All of a sudden my iPhone keyboard has become all exclamation marks after I did a sync. The keys still work and type the correct letter, but the keys themselves only show "!" (see attached picture). It's an iPhone 4G on iOS 5.1.1.

    I've tried going into settings and changing the keyboard from English (UK) to English British, or other countries, and removing English (UK) but that makes no difference. I can get a keyboard if I change from QWERTY to QWERTZ, but who wants to type on QWERTZ?!

    I've tried rebooting a few times, and synchronizing, but to no effect. I'd prefer to avoid wiping my phone and restoring if possible. I also have the Emoji keyboard, but it has been there for many months.

    Can anyone help me please? Thanks in advance.
     

    Attached Files:

  2. RodThePlod macrumors 6502a

    RodThePlod

    Joined:
    Sep 7, 2005
    Location:
    London
    #2
    If you've already tried rebooting/synchronising with no luck then it looks like you may have to wipe/set up as new and then restore your data/apps back on again. It really doesn't take that long.

    You may even find your iPhone a tad snappier in usage as a benefit of having a nice, fresh, clean iOS install :)

    RTP.
     
  3. miss.manson macrumors 6502a

    miss.manson

    Joined:
    Dec 12, 2011
    Location:
    Georgia
  4. CharlieBoyCav thread starter macrumors newbie

    Joined:
    Jun 9, 2012
    #4
    Not Jailbroken

    No, it is not.

    (Also thanks Rod, in passing).
     

Share This Page