iPhone iPhone lost native apps

Discussion in 'Jailbreaks and iOS Hacks' started by 00bolt, Jan 25, 2013.

  1. 00bolt macrumors member

    Joined:
    Mar 3, 2007
    #1
    My son has an iPhone 4s that he basically uses as an ipod.
    it is jailbroken with 5.0.1 i think. he was playing on cydia and downloaded something to change his boot logo and im not sure what else. i know the boot logo wasnt working and he kept playing with it in the settings and restarting the phone... then 30 mins later he comes to me and says alot of his icons on the homescreen are missing

    so things like settings, app store, calendar, etc are no longer there. we did the reset home screen and nothing worked. any ideas? is this something in cydia? we removed winterboard and resprung, etc but still nothing. they are there if you search, but just no icons?
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    Maybe he docked them with sbsettings or another hiding icons program like poof.
    Who knows what he really did.
     
  3. 00bolt thread starter macrumors member

    Joined:
    Mar 3, 2007
    #3
    well he doesnt have poof or sbsettings and he says he didnt do anything purposely trying to hide them. and i believe him cuz hes all upset about it. i tried playing with it for 30 mins and couldnt figure it out
     
  4. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
  5. 00bolt thread starter macrumors member

    Joined:
    Mar 3, 2007
  6. likemyorbs macrumors 68000

    likemyorbs

    Joined:
    Jul 20, 2008
    Location:
    NJ
  7. 00bolt thread starter macrumors member

    Joined:
    Mar 3, 2007
    #7
    since he does not have service, and only uses it for an ipod to play games, etc and he does use a free text/call app to call us when he gets home from school (it uses wifi)...

    what is the best way to restore it and start from scratch? i know he will probably lose all his games and pictures, but is there a way to just reset or restore without having to go through the jailbreak and everything again?
     
  8. Lend27 macrumors member

    Joined:
    Feb 26, 2004
    #8
    Did you reboot or just respring?
    You might try rebooting if you only resprung.
    Also, I had a similar problem and the icons came back when I installed a Cydia tweak. Go into Cydia and reinstall one of your tweaks. That might get your icons back when you respring after installing the tweak.
    Hope that works for you.
     
  9. vtails macrumors newbie

    vtails

    Joined:
    Jun 6, 2011
    #9
    I'd be careful with that restore,,you might make a custom ios5.0.1 and have Redsnow write it.You dont want to update it to 6.X.X because you would lose your Jailbreak till the new J/B come's and it might be a week or 2.
    Something to think about,I am sure it can be restored just make sure you have your SHSH's APTicket's from tinyumbrella or redsnow Cydia make your custom ipsw and go back in redsnow and the more button,Hope you fix it.
     

Share This Page