iPhone Mail Problems

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Maverick1337, Sep 17, 2010.

  1. Maverick1337 macrumors 65816

    Maverick1337

    Joined:
    Nov 4, 2008
    #1
    Hey guys, I have searched for this problem and I couldn't find anyone talking about it so I figured I would ask. When I get a new e-mail, the ping comes in and on the Mail.app it shows the badge for how many new e-mails but when I go into the app, it doesn't show any new e-mails. I refresh and try to load it but it just says "Updated" to such and such time without presenting the new e-mails. Even when I exit the app, it still shows how many new e-mails I have. I go back into the Mail.app and see if it's a new mail from another section (Spam, etc) but no, it shows a new e-mail in the "Inbox" but if fails to show it when I navigate into the inbox. The only way to get these e-mails is to restart my iPhone. Does anyone know how to fix this issue or have had it before and know what to do?

    Also, it's not all the time, it happens a few times a week, but it's pretty annoying. Thanks in advance for the help.
     
  2. thunderbunny macrumors 6502a

    thunderbunny

    Joined:
    Jul 15, 2010
    Location:
    Cheshire, UK
    #2
    This has happened to me ever since iOS 4.0, no idea how to fix it other than restarting the phone. Have reported this via apple feedback site.
     
  3. Maverick1337 thread starter macrumors 65816

    Maverick1337

    Joined:
    Nov 4, 2008
    #3
    Are you on the latest 4.1? Because I'm still on 4.0.1 to be JB'in.
     

Share This Page