iPhone Mobile App Store - Slow Install?

Discussion in 'iPhone' started by aphexii, Jul 21, 2008.

  1. aphexii macrumors 6502

    Joined:
    Feb 22, 2006
    #1
    Just curious if this was just me, or if everyone had this issue. When I install an app via the mobile App Store, it usually takes a good 3-4 minutes until the app is fully installed.

    Anyone else?
     
  2. oftheheavens macrumors 68000

    Joined:
    Jul 9, 2008
    Location:
    cherry point
    #2
    yep, sometimes more depending on the app. and i am guessing that you are doing this without wifi? your are talking about 3g right?
     
  3. gentlegiantcrai macrumors regular

    Joined:
    Sep 25, 2007
    #3
    Yes mine run about 2-3 minutes, the downloads never take long, just the installation.
     
  4. aphexii thread starter macrumors 6502

    Joined:
    Feb 22, 2006
    #4
    No, via Wifi as well. The app downloads fast (usually within 2-5 seconds), but the actual install takes a few minutes.
     
  5. oftheheavens macrumors 68000

    Joined:
    Jul 9, 2008
    Location:
    cherry point
    #5
    yeah that is what i meant about "sometimes more" i was thinking you meant total time it takes. but yes the install can take a few minutes
     
  6. volsfan macrumors regular

    volsfan

    Joined:
    Apr 9, 2008
  7. nickspohn macrumors 68040

    nickspohn

    Joined:
    Jun 9, 2007
    #7
    Really? My downloads and installations are instant.. around 30 seconds. None of them have taken longer than a minute, and i have 20+ apps on my iPhone.
     
  8. redgaz26 macrumors 68020

    redgaz26

    Joined:
    Mar 6, 2007
    Location:
    Glasgow
    #9
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 2_0 like Mac OS X; en-us) AppleWebKit/525.18.1 (KHTML, like Gecko) Version/3.1.1 Mobile/5A347 Safari/525.20)

    same problem here. And a couple of times I've been on using something else whilst waiting for it to install the phone crashes!!!!!
    There's not been one day I've been able to see my usage stats.
     
  9. ejrizo macrumors 6502

    ejrizo

    Joined:
    Jun 26, 2007
    Location:
    Los Angeles
    #10
    i have had the same thing happen to me plenty of times.... but even worse!

    that has happen to me twice now and it wont reboot... just stays stuck at the apple screen.... really annoying since i now have had to restore it for the second time... right now i just finished restoring and before i did anything with the phone i went to "Reset all content and settings" or whatever and told me it could take an hour or so and it sure is taking forever.... but i have a feeling that old files from the Jailbreak days are still around and making my phone bug out..... so setting it up as a new phone no syncs or backups from previous phones and resetting all content and settings...

    hopefully clears everything up and i can just sync and set up all my settings again once everything is erased.

    this whole adding apps from your phone has not beed a good experience for me... i think i am going to stick to adding apps through itunes from now on until a couple of software updates come along to get rid of all the bugs.
     
  10. Snacks macrumors newbie

    Snacks

    Joined:
    Jul 9, 2008
    #11
    Possible Slow App Install Fix

    Seems like I may have fixed it!
    I just did a "Erase All Content and Settings" waited the hour or so for it to complete. When it was done, the phone popped up on iTunes. I did not restore from old settings. I made a new phone name and carried on. At that point I just clicked restore so it would install the 2.0 firmware on it. When 2.0 was installed, iTunes asked to name my phone again, I had to make it a new name *again*, which I did.(I did not restore from old settings) Jumped on the app store and downloaded the facebook app, it downloaded and installed on my phone in under 20 secs. Glad to see it working like normal!!

    Hope this helps you all...

    Update:
    I noticed the more I downloaded and installed apps, the slower the install was. I have 10 apps now and the installing of the apps is nowhere near as fast as it was when I started with my first app. I also tried removing all the apps and going at it from scratch. When I downloaded my first app again, the install went really fast. Can anyone confirm this as well? If this is the case, the above process won't help you. I guess this is more of a firmware issue then anything else.
     
  11. tsvb macrumors 6502

    Joined:
    Jan 28, 2006
    Location:
    Syracuse, NY
    #12
    If you are going over 3G then it will take longer!
     
  12. redgaz26 macrumors 68020

    redgaz26

    Joined:
    Mar 6, 2007
    Location:
    Glasgow
    #13
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 2_0 like Mac OS X; en-us) AppleWebKit/525.18.1 (KHTML, like Gecko) Version/3.1.1 Mobile/5A347 Safari/525.20)

    no my problem is after it's downloaded. It's the install that takes ages. I've restored twice and it's still the same. Good news today is my phones not crashed. First time since I've had it!!
     
  13. mackcrak macrumors newbie

    Joined:
    Oct 20, 2008
    #14
     

Share This Page