iPhone not activating (AT&T)

Discussion in 'iPhone Tips, Help and Troubleshooting' started by AppleSJ511606, Dec 31, 2007.

  1. AppleSJ511606 macrumors member

    Joined:
    Aug 17, 2005
    #1
    I've had firmware 1.1.2 installed on my iPhone for awhile and I got bored with it and wanted to put Apps back on my phone.

    I used iDemocracy to downgrade to 1.1.1 (which I'm currently on now). I have Apps now but what's VERY VERY annoying is the fact that my iPhone hasn't/can't be activated with AT&T for some reason. What reason I cannot figure out. I've been restoring with 1.1.1 and using AppTapp to make the iPhone jump back out of recovery mode.

    I can't get anymore than 1 bar of reception and I'm about to restore the iPhone and let it sit here for ~20 mins since it claims "Activating iPhone, This may take awhile"

    Anybody have any thoughts or ideas on how I can get it activated?
     
  2. AppleSJ511606 thread starter macrumors member

    Joined:
    Aug 17, 2005
    #2
    so apparently I NEEDED to upgrade to 1.1.2 to get SOME sort of reception? could anyone tell me why this is????
     
  3. philgilder macrumors 68000

    Joined:
    Sep 30, 2007
    Location:
    UK
    #3
    because there are 2 firmwares in the iphone, the iphone firmware (all the apple apps etc) and the baseband firmware. the baseband is the thing that controls the wifi, bluetooth and GSM signal

    a new 'feature' in 1.1.2 is that it checks the version of the baseband firmware, and if its found to be old, it will semi 'brick' the iphone

    in order to unbrick it, you need to upgrade to 1.1.2

    when you do a firmware downgrade, it doesnt change the baseband version, hence bricking the phone and making in unable to get signal
     

Share This Page