iPhone not appearing in iTunes

Discussion in 'iPhone' started by mouchoir, Jan 16, 2008.

  1. mouchoir macrumors 6502a

    Joined:
    Apr 29, 2004
    Location:
    London, UK
    #1
    Apologies if this has been covered already, but my search came up with nothing.

    I have just upgraded to Leopard, and now when I connect my iPhone to the mac it doesn't appear in iTunes.

    Would anybody be able to help me fix this?

    Many thanks,
    M

    Just in case –*I am using a non-hacked iPhone running 1.1.3 :)
     
  2. gauchogolfer macrumors 603

    gauchogolfer

    Joined:
    Jan 28, 2005
    Location:
    American Riviera
    #2
    Occasionally I'll have trouble with my iPhone connecting while I'm using Tiger, and it always requires a restart to get it to connect. Not sure what's going on, but there you have it.
     
  3. mouchoir thread starter macrumors 6502a

    Joined:
    Apr 29, 2004
    Location:
    London, UK
    #3
    Thanks for the quick reply!

    I have tried a restart and it didn't work. I have also shut down and restarted the iPhone, and that didn't seem to work either...
     
  4. ert3 macrumors 6502a

    ert3

    Joined:
    Dec 10, 2007
    #4
    ARe you using a mac.

    I get this issue periodically as well and i normally just restart my mac and the problem goes away.
     
  5. mouchoir thread starter macrumors 6502a

    Joined:
    Apr 29, 2004
    Location:
    London, UK
    #5
    Yes –*the problem has just started since upgrading Leopard today.
    Have tried restarting –*will try again!
     
  6. ert3 macrumors 6502a

    ert3

    Joined:
    Dec 10, 2007
    #6
    If the problem persists i remember iTunes getting all kinds of messed up when i upgraded to leopard.

    use spotlight to find a file named com.iTunes.pls or something similar the "com." I am sure of. Delete it. This removes all your itunes settings short of playlists. Try reconecting your iPhone (Note if you sync contacts, callender, email you will need to recheck the boxes)

    Make sure to make a copy of the file just in case.
     
  7. mouchoir thread starter macrumors 6502a

    Joined:
    Apr 29, 2004
    Location:
    London, UK
    #7
    Unfortunately spotlight can't find anything of that name. I also tried parts of it.
     
  8. mouchoir thread starter macrumors 6502a

    Joined:
    Apr 29, 2004
    Location:
    London, UK
    #8
    Okay, crisis over, phew! I reinstalled iTunes 7.6 and that fixed the problem.

    Thanks for all the above help :)
     
  9. jeffreyfort macrumors member

    Joined:
    Feb 15, 2006
    Location:
    Findlay, Ohio
    #9
    when i first installed Leopard it was not pretty. then did the software update and it got better. update and then see if things work better
     

Share This Page