iPhone not being recognized on new MBP

Discussion in 'iPhone Tips, Help and Troubleshooting' started by KWarp, May 13, 2010.

  1. KWarp macrumors newbie

    KWarp

    Joined:
    May 22, 2009
    #1
    Heyo,

    I bought a new Macbook Pro and copied over my user account from my old mac using Migration Assistant.
    When I plug my iPhone 3GS into my old mac, both iTunes and XCode know it's plugged in.
    When I plug my iPhone 3GS into my new mac, iTunes and XCode have no idea that it is there. No response whatsoever.

    Is there any sort of plist file I can reset?
    I would prefer not to erase my iPhone if I can help it.
     
  2. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #2
    Try reinstalling iTunes. Also are the iTunes versions the same from the old to the new Mac?
     
  3. KWarp thread starter macrumors newbie

    KWarp

    Joined:
    May 22, 2009
    #3
    Yes, I used migration assistent, so the versions of iTunes are exactly the same.

    I will try reinstalling both iTunes and XCode.
     
  4. KWarp thread starter macrumors newbie

    KWarp

    Joined:
    May 22, 2009
    #4
    Seems like the issue magically fixed itself. I did nothing, but the iPhone is recognized now.
     
  5. macfan246 macrumors newbie

    Joined:
    May 17, 2010
    #5
    The issue didn't happen to resolve itself when you changed USB ports did it? I believe there is a problem with the front USB port on the new i7 15" MacBook pros and I'm trying to gather evidence. Any feedback would be appreciated.
     

Share This Page