iPhone not receiving iMessages

Discussion in 'iPhone' started by Classiclays, Feb 28, 2015.

  1. Classiclays macrumors member

    Joined:
    Feb 28, 2012
    #1
    I've always turned off iMessage on my iPhone, as I rather receive my messages through text rather than through cellular data. It worked perfectly until now.

    When I upgraded my Mac to Yomesite OSX, the "hand-off" feature began to send iMessages to my computer, without notifying me on my phone. After a few days of missed texts, I finally realized what was happening. I tried playing around with the settings but I could not figure out how to get the messages on my phone. I even turned on iMessage on my phone as a last resort and am still missing messages.

    Does anyone know how to fix it? I would rather disable iMessage on my computer than not get messages on my phone.
     
  2. I7guy macrumors G5

    Joined:
    Nov 30, 2013
    Location:
    What Exit?/Saguaro Country
    #2
    Why can't you turn off the forwarding feature on your iPhone, sign out of iCloud ( on both) and iMessage on iPhone and then sign back into iCloud and iMessage?

    Seems that should fix the issue.
     
  3. Classiclays thread starter macrumors member

    Joined:
    Feb 28, 2012
    #3
    The text messsage forwarding on my phone was already off, so I'm a bit confused.

    I'll try signing in and out but I'm not sure if that will help.

    Thanks for the response, will report back.
     
  4. Classiclays thread starter macrumors member

    Joined:
    Feb 28, 2012
    #4
    I signed off iMessage on my computer and turned off iMessage on my phone. Seems to be working now.
     

Share This Page