iPhone not recognised by Macbook Pro when connected via USB

Discussion in 'iPhone Tips, Help and Troubleshooting' started by D.D, Sep 13, 2013.

  1. D.D macrumors newbie

    Joined:
    Sep 13, 2013
    #1
    Hi all,

    I have searched and scoured the internet for the last 3 days and have come up with nothing for my issue. I created this account because I always use Macrumors to solve any issues I have but it seems this may be unique to me.

    My iPhone 5 (iOS 6, latest version, I think it's 6.1.4) cannot connect to my Macbook's USB. When I plug it in, nothing happens and it just sits there.

    Here is what I have tried and thought of so far:

    1) Issue with cable? No, it works with other computers and also the wall socket charger. Also, it is brand new, bought not long ago.
    2) Issue with iPhone 5 lightening connector port? No, if I connect it to other computers and the wall it comes up as 'connected' or 'charging'
    3) Issue with the USB ports on the Macbook? Again, no. If I plug in my iPod or iPad, they work no problem. Also, other USB sticks have no issue.

    The Macbook just got updated there last night to the latest OSX 10.8.5 but it didn't fix anything. Based on what I have described above, it is definitely a software issue and not a hardware one. Thoughts?

    The iPhone connects to iTunes for syncing through WiFi, but I want to connect via USB to install iOS7. And I can still charge using a plug, so I'm not completely stuck.

    I'm out of ideas and at my wits end. If anyone has any ideas, let me know.
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    Maybe try a hard reboot of the phone. Hold the home and power buttons both down until you see the Apple logo then let go and it will reboot.

    I am assuming since you updated to 10.8.5 you have checked for the latest iTunes updates also.
     
  3. D.D thread starter macrumors newbie

    Joined:
    Sep 13, 2013
    #3
    I do have the latest software on the iPhone and Macbook. I have also tried the hard reboot on the phone and still nothing...
     
  4. Mrbobb macrumors 601

    Joined:
    Aug 27, 2012
    #4
    The question beg to be answered: Did it EVER work with this laptop?

    While u answering that I want to know whether when you open iTunes, under preference -> devices, does your device shows up (even before u plug it in) and whether the checkbox that says something like "Prevent device from updating automatically when plugged in" is checked or unchecked.
     
  5. D.D thread starter macrumors newbie

    Joined:
    Sep 13, 2013
    #5
    Yeah, I had a 3GS before the iPhone 5 and it worked no problem. I've had the iPhone 5 since launch last year and it has worked no problem.

    In another thread someone else is having the exact same problem. The phone was plugged in, doing nothing, just syncing genius results. It was finished, so the phone was just charging. Then it just logged itself out and it would never show up again. But it also doesn't even charge, never mind show up which is really weird.

    That's why I tried this phone in another machine, and it shows up and charges no problem (but that's not my machine). Also, my iPad and iPod still can charge and sync by USB to this machine, so there is also no issue there.

    It is just so strange and really frustrating.

    And to answer your last question, the phone does show up as it still connects through WiFi, and the box you mentioned is unticked.
     
  6. Mrbobb macrumors 601

    Joined:
    Aug 27, 2012
    #6
    This is a classic reason why I maintain image back ups of my OS and when something go awry I just restore to the last point when everything worked. I do not know whether ur backup situation allows.

    Last resort, restore to factory and set aside a whole weekend. :(
     
  7. The Icefish macrumors newbie

    Joined:
    Sep 18, 2013
    #7
    I am having the same problem. Please let me know if you find a solution.
     
  8. charlituna macrumors G3

    charlituna

    Joined:
    Jun 11, 2008
    Location:
    Los Angeles, CA
    #8
    very possibly a software issue. most likely something in 10.8.5 or your user data.

    process of elimination will generally sort it out.

    update itunes if it's not current. if that doesn't work then try creating a new user account to see if it's something in your user data.
     
  9. frenchtony macrumors member

    Joined:
    Jan 3, 2013
    Location:
    London
    #9
    Might have found what the problem was...

    I had the exact same problem, trying to connect my wife's iphone to her itunes in her session.
    Turned out that, on my own session, i had Parallels (virtualisation software) running, which is probably "highjacking" the USB ports in some way.
    Turning Parallels off solved the issue.
     

Share This Page