iPhone not recognized by Mac

Discussion in 'iPhone Tips, Help and Troubleshooting' started by earwig, Mar 15, 2010.

  1. earwig macrumors newbie

    Joined:
    Mar 15, 2010
    #1
    I have 2 iPhones, mine and the wifes. Both 2G and both on 3.0 and unlocked and j/b by using RedSn0w

    For a few months now I have not been able to get my iPhone to show in iTunes or on the Mac at all.

    I have tried numerous different ideas and tips but nothing seems to work.

    So far if I put the iPhone into DFU mode nd plug the USB in it shows on iTunes as a phone in recovery mode. But it will not let me restore.

    I have deleted applemobiledevice, itunes etc and re-installed them which did work once, but only once and has gone again.

    I have tried Pwnagetool and that won't recognise it either.

    The other phone works fine though all the time.
     
  2. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #2
    If this is how you think you are doing DFU mode, you're doing it wrong. See my sig.
     
  3. earwig thread starter macrumors newbie

    Joined:
    Mar 15, 2010
    #3
    No, it is definitely in DFU mode, but for some reason iTunes thinks it is recovery mode. It is a black screen, not the iTunes USB logo.

    Also forgot to mention I have checked all the cables, even got a new Mac and it still doesn't show on that.

    I have a feeling it might be the connector on the bottom of the phone, but it still charges and did come back on the other day, a fluke perhaps?
     
  4. earwig thread starter macrumors newbie

    Joined:
    Mar 15, 2010
    #4
    it gets worse

    After giving up again, I plugged it in to charge tonight and ping, up popped iPhoto.

    I checked iTunes and there it was. Great I thought, so I thought now is my chance to update the FW on it. I clicked on Restore and off it went with the Apple logo and the progress bar at the bottom, but the progress bar didn't move. 5 minutes later and now the phone is stuck in a Restore loop.

    Tried numerous ideas to get it back on but no luck.

    I can't use most things as it doesn't register as being connected, again. So they just sit there waiting for iPhone to be connected. Tried another restore by going into DFU mode but now instead of the Apple logo I get a white screen when it attempts it and it hangs until I reboot the phone.

    At a complete loss now. :(
     

Share This Page