iPhone Not Ringing (when receiving incoming calls)

Discussion in 'iPhone Tips, Help and Troubleshooting' started by linsam, Oct 1, 2009.

  1. linsam macrumors 6502

    linsam

    Joined:
    Jul 3, 2007
    Location:
    Irvine, CA
    #1
    Hi All,

    Something strange is happening. My iPhone is not ringing when it has incoming calls. All calls go directly to voicemail. The phone is not on mute. I do get text and email notifications, but no ring. I have done a hard reset, but this has not resolved the issue.

    Has this happened to anyone else? If so, did you find a fix? All feedback is greatly appreciated.

    Linda
     
  2. twisted-pixel macrumors 6502a

    twisted-pixel

    Joined:
    Sep 13, 2009
    Location:
    San Jose, CA
  3. sparkomatic macrumors 6502a

    sparkomatic

    Joined:
    Jun 8, 2007
    Location:
    Orange County, CA
    #3
    I'm in SoCal and, last night for about 4 hrs, I was having the same problem. Internet, emails, texts...all worked fine. However, I could not make or receive calls. It was weird. I reset my phone as well but that didn't help.

    Phone service eventually kicked in again. I even went online to see if AT&T was having some kind of problem but didn't find anything.
     
  4. Moi un Mouton macrumors 68000

    Joined:
    Mar 18, 2008
    Location:
    Bracknell UK
    #4
    Can you make calls?

    And are you on firmware 3.1? I think a lot of people have similar issues since the update.
     
  5. linsam thread starter macrumors 6502

    linsam

    Joined:
    Jul 3, 2007
    Location:
    Irvine, CA
    #5
    Hi --- YES --- I am running 3.1. Things are a bit better today. I am now at work and got a call. Yeah! It was nice to hear the ring, again. However, while I was at my house today, I called my iPhone from our land-line and it did not ring. I am wondering if this strange behavior has something to do with my reception at home. It has been okay up until now.
     
  6. linsam thread starter macrumors 6502

    linsam

    Joined:
    Jul 3, 2007
    Location:
    Irvine, CA
    #6
    Hi --- Are you up and running normally today? I am also in SoCal.
     
  7. Moi un Mouton macrumors 68000

    Joined:
    Mar 18, 2008
    Location:
    Bracknell UK
    #7
    I would try this when you are home again:

    - call the iphone, see if it rings. See if it is showing a signal

    - if it doesn't, put it into airplane mode for a few seconds, to turn the phone antenna off. then put it back to normal and see if it shows a signal. Call it again, see if it rings.

    - again, if it doesn't, turn the phone right off (not sleep, power off), then power on again, see if it gets a signal. Call it again, see if it rings.

    If at any stage you have a signal but it won't ring, take it back to Apple and ask for an exchange.

    If you're not getting a signal and that's the reason for the calls going to voicemail, check with AT&T what's causing that.
     
  8. SFStateStudent macrumors 604

    SFStateStudent

    Joined:
    Aug 28, 2007
    Location:
    San Francisco California, USA
    #8
    I've updated to the 3.1.2 FW and all of a sudden my iPhone doesn't ring either. Vibrates just fine, but I don't want it to vibrate, I need it to ring. Had about 22 voicemails in a matter of three days. Any suggestions? I've restored 6-7 times and had a gazillion contacts (1499 v. 750) and I've had to go in and manually delete these contacts. I'm ready to take this one back....:mad:
     
  9. MacKenzie999 macrumors regular

    Joined:
    Jan 24, 2002
    Location:
    Boston
    #9
    Same problem

    I'm on a 2G (8gb) iPhone I've had since day one, and lately have been experiencing the same problem. I'm wondering if an upgrade to a 3Gs might fix this, although mainly because I'd like to upgrade my phone, but can't decide if I should wait for the non-AT&T version this summer (don't like AT&T, don't like the $15 rate-hike I'll get when I upgrade).

    Any opinions?
     
  10. rafale macrumors newbie

    Joined:
    Jun 27, 2009
    #10
    Have been having the same problem with an Iphone4 on 4.1. I had never had this problem before on 4.0.1 or even on a 3G network in asia also on 4.1.0.
    I am on T-mobile with an unlocked phone. The problem has been intermittent for me and sometimes recovers after a reboot of the phone. What I just found out is that I can also turn the problem off by switching off the data service on my phone. The problem reappears only when I try to turn the 2G data service back on and try to use it so I think it has to do with either the carrier doing something funny with my data plan or my unlock not working as it should on 4.1...
     
  11. jabuka macrumors newbie

    Joined:
    Nov 7, 2010
    #11
    Exactly the same situation as above, looking forward to the replies. Have a 3GS, FW4.1, bb 06.15.00, just unlocked.
     
  12. rlbcandw macrumors newbie

    Joined:
    Dec 9, 2010
    Location:
    Houston
    #12
    Iphone 3GS not ringing unlocked Tmobile

    I am having the same issue.
     

Share This Page