iPhone not syncing calendar with Mobile Me

Discussion in 'iPhone' started by yg17, Jul 6, 2009.

  1. yg17 macrumors G5

    yg17

    Joined:
    Aug 1, 2004
    Location:
    St. Louis, MO
    #1
    Yesterday, I made a change in iCal to an event. The change is reflected on me.com, but not on my iPhone. I guess it just stopped syncing calendars or something, I dunno. I just added a test contact in me.com and it appeared on my iPhone instantly, and when I deleted it, it also immediately disappeared from my phone, and emails are pushing, but something's preventing the calendar from syncing. Anyone ever seen this before and know how to fix it?

    Edit: Nevermind, I'm an idiot. The change to the event did sync, I was changing the end time and made a typo in iCal so the end time was still incorrect, which threw me off.
     
  2. tivoboy macrumors 68030

    Joined:
    May 15, 2005
    #2
    delay

    There IS also a bit more DELAY with calendar events updating on the iphone than there should be. I can look at the calendar for a minute or so, no changes and then BOOM the changes just pop up.
     
  3. brn2ski00 macrumors 68020

    brn2ski00

    Joined:
    Aug 16, 2007
    #3
    but this is correct, there can be a variety of network factors that can delay push updates.
     
  4. tivoboy macrumors 68030

    Joined:
    May 15, 2005
    #4
    sorry

    I'm sorry, I should have clarified my comment.

    I don't have push turned on, but use MM. Push on MM drained the battery too fast for me.

    So, I do have to go into the email for my .me account and sync, before it will sync the calendar items that are ON me.com, from either my ical updating them, or directly on me.com.

    So, once the sync is completed, finishes, no more spinning wheel, nothing spinning in the menu bar, I can check the calendar, and lo and behold, the updates are not there.

    But, scroll around a bit, they are still not there. But, a few 10+seconds LATER they do suddenly appear shifting things around miraculously disappearing if deleted elsewhere or appearing if added somewhere else.

    I don't know why it would have updated already if I did the sync, but this is the way it seems to work. For a while there, I thought the updates weren't coming across at all, even on PUSH, but it just took a few minutes to populate the data I guess.
     

Share This Page