iPhone only syncing some apps with iTunes 9

Discussion in 'iPhone Tips, Help and Troubleshooting' started by MICMAC247, Sep 15, 2009.

  1. MICMAC247 macrumors regular

    MICMAC247

    Joined:
    Jul 21, 2009
    #1
    Hello!

    I have searched the forums and Google and it appears I may have a Unique issue with my iPhone 3Gs. Here is a little background…

    • I recently moved my iTunes music from my old PC to my new Mac (I love it! Thanks for asking!)
    • I upgraded the iTunes on my Mac to 9.0. The iTunes on my PC was not upgraded.
    • I had been using my iPhone with the Mac, but I never did a full sync, fearing I would lose some data and have to go through the headache of re-downloading and finding my apps.
    • Yesterday, I read some posts on importing iPhone backup from windows to OS X. I backed up my iPhone on the PC and copied over the files from the Mobilesync folder and got them onto the Mac without any issues.
    • I did a restore of the iPhone using iTunes on my Mac. And then loaded the new backup information onto the phone through restore.
    • Music, Photos (through iPhoto), Videos, and Podcasts are syncing fine. However, there appears to be an issue with the applications.
    • I noticed some apps were missing, so I copied the contents of my apps folder from the PC to the Mac.
    • After doing so, I added them to applications library, and I was able to view them all on my Mac in iTunes 9.

    Here's where the issues start. Strangley enough, I set up how I wanted the applications laid out on the phone in iTunes 9, synced and went into the home screen. What's weird is that there are several applications missing, and where they are supposed to be on my screen there are empty slots. I cleared the applications off my phone, and tried to sync back the applications and I have the same issue.

    The only thing I think I may consider doing is upgrading the PC to iTunes 9, creating a new iPhone backup there, and then bringing that over to the Mac and try restoring with another new backup.

    Any thoughts? Anyone else having this issue?
     
  2. HighLife420 macrumors 6502a

    Joined:
    Jul 25, 2009
    #2
    i think the app arrangement feature only works if you have 3.1 installed on your iphone...

    i dunno if it would mess with the sync of the app itself...but if you not on 3.1 (dont specify in your post if you are or not, so im assuming you are not), it will certainly account for the problem when you try to arrange the icons in iTunes.
     
  3. MICMAC247 thread starter macrumors regular

    MICMAC247

    Joined:
    Jul 21, 2009
    #3
    Hi! Sorry, I forgot to mention that I am on 3.1. I am not sure what the issue could be. I suppose I may have to just do a clean format and start from scratch.
     
  4. HighLife420 macrumors 6502a

    Joined:
    Jul 25, 2009
    #4
    i would, start over fresh too, dont use a backup....
     

Share This Page