iPhone OS 4.0 A2DP Bluetooth

Discussion in 'iPhone' started by CaryMacGuy, May 18, 2010.

  1. CaryMacGuy macrumors 6502a

    CaryMacGuy

    Joined:
    Oct 2, 2006
    Location:
    Morrisville, NC
    #1
    I was just wondering if anyone has noticed an option to disable A2DP streaming in OS 4.0? I have a car where when I turn it on, the music starts streaming from my phone to my car no matter what source I am in. I want to be able to disable it so that doesn't happen.
     
  2. Raegor macrumors member

    Joined:
    Mar 4, 2010
    #2
    Don't all phones have the ability to turn it off? (just an assumption)
     
  3. CaryMacGuy thread starter macrumors 6502a

    CaryMacGuy

    Joined:
    Oct 2, 2006
    Location:
    Morrisville, NC
    #3
    Not the iPhone...not stock and I am too scared to Jailbreak
     
  4. gr8whtd0pe macrumors 6502a

    gr8whtd0pe

    Joined:
    Feb 21, 2008
    Location:
    Belle, WV
  5. xcrunner macrumors regular

    Joined:
    Dec 17, 2007
  6. jbro1999 macrumors regular

    Joined:
    Nov 24, 2009
    #6
    No it's not.

    I have the same problem. If you disable it you can't use the phone thru the cars speakers. I really hope they address this issue. It's a drain on the battery.

    BTW - Cary mine is jailbroken but I haven't been able to find anything that really solves the problem.
     
  7. xcrunner macrumors regular

    Joined:
    Dec 17, 2007
    #7
    When it's playing music on the phone iPod app click the bluetooth icon and choose speaker.
     
  8. CaryMacGuy thread starter macrumors 6502a

    CaryMacGuy

    Joined:
    Oct 2, 2006
    Location:
    Morrisville, NC
    #8
    But to have to do that every time I get in my car and start it.
     
  9. Reluctant Adept macrumors member

    Joined:
    Jan 30, 2009
    #9
    What are you listening to your music on? You definitely shouldn't be listening on headphones while driving.
     
  10. jbro1999 macrumors regular

    Joined:
    Nov 24, 2009
    #10
    It comes out the speakers of the car, if you have bluetooth audio on. If not, it just tries to play the ipod anyway for no reason.
     
  11. xcrunner macrumors regular

    Joined:
    Dec 17, 2007
    #11
    Doesn't you car let you choose what profiles/options you want enabled? or what about if you unpair/repair are you given an option to not use the a2dp option.
     
  12. jbro1999 macrumors regular

    Joined:
    Nov 24, 2009
    #12
    Nope. He has the SYNC like I do. I have talked to Ford and they said this is Apples problem. It worked fine with 3.0 but when 3.1 came out it screwed everything up.

    As soon as you turn the car on it pairs with your phone. Which is great, the only thing is that pairing turns on the ipod and it starts playing everytime. It sucks taking your phone out to close the app.

    If you turn off Bluetooth you can't call out using SYNC.
     
  13. graham1971 macrumors member

    Joined:
    Apr 23, 2010
    #13
    I also want to know if ios 4 has an option to turn off a2dp.
     
  14. zacheryjensen macrumors 6502a

    zacheryjensen

    Joined:
    May 11, 2009
    #14
    So the problem is that you are too troubled by having to press pause? Also, fyi, I use A2DP headphones and when they are paired IT DOES NOT START PLAYING AUTOMATICALLY. Therefore, this is a problem with your SYNC system deciding it should hit "Play" whenever it pairs to an A2DP device.

    Blame the right idiots.
     
  15. jbro1999 macrumors regular

    Joined:
    Nov 24, 2009
    #15
    It is annoying and I shouldn't have to take the phone out of my pocket. That's the whole point of it. I found a work around, just take all the mp3s off of your phone, jailbreak and use Grooveshark. So much better. I can play what I want when I want.

    It was correct before 3.0. 3.1 messed it up.
     
  16. pdqgp macrumors 68020

    pdqgp

    Joined:
    Mar 23, 2010
    #16
    So when it worked correctly on OS 3.0. but changed and got messed up on OS3.1 blaming Ford is putting accountability in the correct place? I don't think so. It's an Apple thing and issue they should fix. I have Sync in my Company Car - Fusion Sport and it does the same thing.
     
  17. rKunda macrumors 65816

    rKunda

    Joined:
    Jul 14, 2008
    #17
    SYNC needs a non A2DP bluetooth option. I've tested my headset with A2DP vs standard and this does indeed happen with A2DP on. Turn on a paired A2DP device and the music starts coming through it. I could see this as being a 'feature.' Ideally, you want SYNC to pair as a handsfree device, not A2DP.
     
  18. graham1971 macrumors member

    Joined:
    Apr 23, 2010
    #18
    I'm having problems with my Bury CC 9060 car kit and a2dp. When it pairs with the iphone the iphone wants to use a2dp and play music via the Bury, but I don't want that because I have the iphone connected to my head unit via a cable. The only fix is to unplug the iphone and plug it back into the cable AFTER it has paired with the Bury. I have to do this everytime I stop and start my car. If the Bury or the iphone had an option to turn off a2dp I would not have this problem.
     
  19. graham1971 macrumors member

    Joined:
    Apr 23, 2010
    #19
    Unfortunately iOS 4 still doesn't have an option to turn off a2dp. Very annoying.

    On top of that the new OS has a few issues with my car's head unit.
     
  20. jbro1999 macrumors regular

    Joined:
    Nov 24, 2009
    #20
    yup. slowly getting there.
     
  21. iMerlin macrumors 6502a

    iMerlin

    Joined:
    May 13, 2008
    #21
    Not sure if this helps but my Sony XPLOD has A2DP and I can press the number 6 on the face to pause and play music. So no need to take the phone out of my pocket. Although, mine doesnt start playing right away.
     
  22. TheBigYahi macrumors newbie

    Joined:
    Jun 28, 2010
    #22
    It's the stereo, not the phone. I use A2DP (in horrible quality) in my Sorento and it doesn't start playing until I hit the AUX button. Before that the phone pairs and is good to go for handsfree calling. Keep pushing on Ford (Microsoft?), it's their problem.
     

Share This Page