iPhone OS 4.0 Beta 3 back up "refused request" on iTunes

Discussion in 'iPhone' started by qcom, May 30, 2010.

  1. qcom macrumors newbie

    Joined:
    Aug 2, 2009
    #1
    Hello everyone,

    When I connect my iPhone (running the OS4 Beta 3) to my iMac (running Leopard) and try to sync my phone, including backing it up, it gives me the following prompt EVERY TIME:

    iTunes could not back up the iPhone "_____ iPhone" because the iPhone refused the request.

    And I hit OK. I would really like to fix this problem, as before I upgrade to Beta 3, I would really like to back up all of my data. The problem is, I hear the only fix is to download the newest Xcode, which only works on the Snow Leopard operating system.. I wouldn't necessarily mind upgrading, because I'm going to be selling this iMac soon anyway, and it should give me an extra mark up value..

    But, in the mean time, is there any way to back up this iPhone without upgrading to Snow Leopard on my iMac?


    Thanks!
     
  2. Chundles macrumors G4

    Chundles

    Joined:
    Jul 4, 2005
    #2
    This is because you don't have the 4.0 SDK beta installed.

    Just log into your developer account and install it.
     
  3. qcom thread starter macrumors newbie

    Joined:
    Aug 2, 2009
  4. fishkorp macrumors 68020

    fishkorp

    Joined:
    Apr 10, 2006
    Location:
    Ellicott City, MD
    #4
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_0 like Mac OS X; en-us) AppleWebKit/532.9 (KHTML, like Gecko) Version/4.0.5 Mobile/8A274b Safari/6531.22.7)

    Yes, SL is required.
     

Share This Page