iPhone OS4 and Email Threading Problem w/ Exchange Accounts

Discussion in 'iPhone' started by dhy8386, Jun 8, 2010.

  1. dhy8386 macrumors 6502a

    Joined:
    Aug 13, 2008
    #1
    All,

    I am having an issue with my corporate exchange account and email threading. I have not used this feature in previous OS4 beta builds but was recently looking through changes in the OS4 GM and decided to turn it on and check it out. It works fine for gmail, mm, and yahoo. But here is the problem with my Exchange mail. I sync 1 month of my corporate email. None of the email thread initially. Now i open an email that is part of a thread. Close it. Then i open another email in that thread, close it. Now its threaded. However, the other emails in the thread do not fall under thread view until i open each one and let the content load. I am wondering is this is an issue where only headers download initially and this until i go in, the OS does not recognize the emails as part of a thread. On the other hand, not sure this is necessarily right cause i can open emails on the subway as an example where there is no service and emails on my phone open fine with all the content. These are emails of all sized, not necessarily ones with attachments or that are very big.

    Any thoughts or suggestions would be welcome. I tried the obvious - restart, turning on and off threading.

    EDIT: I just noticed that many many of my Exchange emails, if i turn off connectivity, and go into unopened emails, i get a "This Message Had Not Been downloaded from the server". Is there anyway to modify how the phone is dowloading the messaged?
     
  2. Peace macrumors Core

    Peace

    Joined:
    Apr 1, 2005
    Location:
    Space--The ONLY Frontier
    #2
    Have you tried the developers forums at the Apple dev. site ?
     
  3. dhy8386 thread starter macrumors 6502a

    Joined:
    Aug 13, 2008
    #3
    Good suggestion. I did and some suggested to delete and re-add, even multiple times. I did and now it works. Very strange but what are you going to do...
     

Share This Page