iPhone photos not displayed

Discussion in 'iPhone Tips, Help and Troubleshooting' started by mhpok184, Dec 25, 2007.

  1. mhpok184 macrumors newbie

    Joined:
    Oct 6, 2007
    #1
    I'm visiting Canada for a few days. I individually deleted each photo from my folder. There were no photos remaining in "Photo Albums." When I took a photo with the "Camera" feature the shutter snapped a photo and the photo moved to the icon in the lower left corner. Attempting to open the photo in the "photo album" feature resulted in the message "No Photos." I reset the iPhone with still no luck.
     
  2. philgilder macrumors 68000

    Joined:
    Sep 30, 2007
    Location:
    UK
    #2
    you sure youre opening 'camera roll' rather than 'photo library'???
     
  3. mhpok184 thread starter macrumors newbie

    Joined:
    Oct 6, 2007
    #3
    iPhone photos not saved

    Yes,with my iPhone the "Camera Roll" page is opened and reads, "No Photos...you can take photos using the camera." when i select the camera icon i view the image on the screen....shutter snaps....photo moves to icon (album icon?) in lower left corner. As i open the "Photos" icon in the main menu it still reads "Photo Albums...no photos"---the same message reads on the "Camera Roll" page.
     
  4. HiRez macrumors 603

    HiRez

    Joined:
    Jan 6, 2004
    Location:
    Western US
    #4
    I'm having the same problem. I've had my iPhone for about 4-5 months and have taken hundreds of photos and never had a problem. But now it started doing this. I took a bunch of pics and now they are simply not there in the camera roll. This was just after updating to 1.1.3, I wonder if that's related?

    I tried restarting the iPhone (completely) and it's still doing it, anyone have a solution? It's a terrible bug because I really want those photos back, they are irreplacable. I don't know if they're on the phone but the phone is not showing them, or if they never got recorded in the first place. And I can't even take any new photos now.

    EDIT: had the wrong version number
     
  5. nightdweller25 macrumors 6502

    Joined:
    Mar 2, 2005
    #5
    Oh my God, I'm having the exact same problem! It's really disheartening! I thought I was the only one.
     
  6. HiRez macrumors 603

    HiRez

    Joined:
    Jan 6, 2004
    Location:
    Western US
    #6
    Has it been happening for a while or did it just start happening after the 1.1.3 update right around MacWorld? Trying to determine if the update is causing this. I ended up having to completely reset the phone to fix it. Restoring the backup after reverting to factory settings re-enabled the bug, which I find interesting (because I thought it only would back up user data, not code where you'd think a bug would be living), but I can't explain it. It's really annoying, lost all my non-synchronized settings. It'd be nice if you could backup/restore/sync just the phones settings and preferences (stocks, weather, brightness, etc.).
     
  7. ckeilah macrumors newbie

    Joined:
    May 13, 2009
    #7
    same here

    Apple can't seem to keep the camera working. Remember when iPone first came out and if you "delete all photos" after importing them to iPhoto the camera would break? We had to import all our photos, then manually delete all but ONE. Here we are again.

    While I'm at it, why can't Safari seem to run for half a day without crashing?
     
  8. gloanova macrumors newbie

    Joined:
    Jun 19, 2009
    #8
    has anyone found a fix for this yet? NOTHING seems to work! help :(
     
  9. sea-la macrumors newbie

    Joined:
    Sep 30, 2009
    #9
    add'l data point...

    I've been having the same problem. When I open the photo library, it says: "Camera Roll (806)", but when opening the roll, there are only 759 photos. And the most recently taken pic is the thumbnail associated with the Library.

    An additional data point is that in the iPhone's Setting's interface, in the About screen, it also lists the number of photos as 759.

    But, the photos are in fact in the library because they are still able to be copied onto my laptop using iPhoto. They just can't be seen on the phone - which means I can't email them, upload to facebook, etc. from the phone. Very, very frustrating.

    The guys at the Apple store had no clue how to resolve. All they were able to suggest was a reset.
     
  10. A2,304 macrumors newbie

    Joined:
    Dec 20, 2009
    #10
    Good News

    The photos are still there. I have the same problem and they import to iPhoto just fine. I think resetting the phone or updating firmware may be the only way to fix it.
     
  11. FrankieH macrumors newbie

    Joined:
    May 29, 2010
    #11
    iPhone Photos

    Hi Guys,

    I bought the iPhone 3gs last august (so youd think by now I'd have half a clue what I'm doing?!....). I tried uploading a few photo albums today onto my iPhone and on the photo folder list the picture that usually shows to the left of the title isnt there ... its just a white box! Does anyone know how to fix this?? All of my other albums are fine its just the ones from today. Also I put a compilation album on it and I know that there is a new setting on the iTunes that requires you to tick a box to ensure that it all loads into one album (part of compilation tick box) however, this one album is on the phone 34 times all under different artists ... any idea how to sort this??

    Any suggestions please xxx
     
  12. vwrob macrumors newbie

    Joined:
    Jul 15, 2010
    #12
    the pictures are there yoiu just have to look deeper

    i thought i lost about 300 photos out of my camera roll aswell after i synced my iphone last. . if you plug your phone in and explore the harddrive of the iphone u will see them and can back them up onto your computer. i've done this and it worked.. still cant see them in the actual iphone camera roll but they are there. i,m attempting to sync my photos again tonight and see if it corrects this problem.. i just didnt want to sync before i backed up my pix the old fashioned way. thank mr. jobs for making me think i lost my pix.. damn u cool os4 update.. damn u..
     

Share This Page