Become a MacRumors Supporter for $25/year with no ads, private forums, and more!
  • Did you order new AirTags? We've opened a dedicated AirTags forum.

Acejam2k

macrumors regular
Original poster
Jul 16, 2008
234
9
Hey all,

I'm trying to access a company intranet website through my company's VPN. We have a simple PPTP VPN server. (MS Server 2k3)

I'm able to connect fine. I'm able to browse to one of our intranet sites via IP address fine. But I cannot browse using hostnames or fully qualified domain names. (FQDNs) All of this si being done through Safari obviously.

Therefore, this means there is a DNS resolution issue. In VPN settings, I've tried setting "Send all traffic" to both on and off, and neither works. (should be on though)

Has anyone else got this to work using either PPTP or even L2TP? (and not CISCO)
 

rizajj

macrumors member
Jul 17, 2008
87
0
same problem here. can VPN into our MS PPTP VPN, but cannot do anything with FQDNs, only IPs.

From my 'research', it appears that one major issue is that OS X (and I'm assuming the iPhone OS) uses the ".local" extension for Bonjour services. Is your VPN's domain end in ".local"? That could be part of it. In OS X, you can just say that ".local" domain should be included in the VPN settings for traffic. But we dont have that option on the iPhone.

So, my impression is, if you have a ".local" domain, it simply won't work. Bummer.


Someone prove me wrong!!!
 
Comment

JamboUK

macrumors member
Jul 12, 2007
65
0
I was just doing a search for the solution to the exact same problem. I can use IP addresses to go where I want on the network once VPN is established but I cannot use DNS - which is ideally what I need.

My router is a Vigor (so again no Cisco) and I connect using PPTP. Be nice to have some help on this!!
 
Comment

JamboUK

macrumors member
Jul 12, 2007
65
0
same problem here. can VPN into our MS PPTP VPN, but cannot do anything with FQDNs, only IPs.

From my 'research', it appears that one major issue is that OS X (and I'm assuming the iPhone OS) uses the ".local" extension for Bonjour services. Is your VPN's domain end in ".local"? That could be part of it. In OS X, you can just say that ".local" domain should be included in the VPN settings for traffic. But we dont have that option on the iPhone.

So, my impression is, if you have a ".local" domain, it simply won't work. Bummer.


Someone prove me wrong!!!

and yes we also have a .local domain.
 
Comment

tjmarques

macrumors newbie
Aug 22, 2008
2
0
disable ipv6

I was having the same problem on my mac and completely disabling ipv6 in vpn settings worked. maybe the same holds true for the iphone?
 
Comment

Blackforge

macrumors 6502
Mar 8, 2008
269
13
FQDNs via my work's MS PPTP VPN work fine for me. Using just the hostname does not work though. Our internal domain ends in .com though.
 
Comment

bradhs

macrumors regular
Jun 5, 2010
103
38
iPhone 4 and same problem... Anyone know of a solution? I really need this to work.

Everything is dhcp, so that would be automatically. It sounds like there may be an issue with .local domain extensions.

 
Comment

lhs0002

macrumors newbie
Aug 5, 2010
1
0
Iphone 3Gs - IO 4.0 Vpn OK now

I'm not use to take part of a forum, Iphone VPN , I think find the bug,
After finish you conf in VPN , just on /off then when he try to connect, go back to the conf and you will see the DNS to reach, just push your finger on the DNS to force VPN to use this DNS.
Voila Thanks. For me it work, otherwise you can also use GuizmoOVPN.:)
 
Comment

bradhs

macrumors regular
Jun 5, 2010
103
38
I didnt find any DNS settings/status/config while the VPN is on or off.

Maybe that's the issue? The iPhone is not properly requesting/receiving DNS from the Microsfot RRAS server.

I'm not use to take part of a forum, Iphone VPN , I think find the bug,
After finish you conf in VPN , just on /off then when he try to connect, go back to the conf and you will see the DNS to reach, just push your finger on the DNS to force VPN to use this DNS.
Voila Thanks. For me it work, otherwise you can also use GuizmoOVPN.:)
 
Comment

lorenz meier

macrumors newbie
Oct 6, 2010
2
0
Hey all,
Has anyone else got this to work using either PPTP or even L2TP? (and not CISCO)


Here's the solution if you are using the open source PPTPD server (my example: Ubuntu 10.04). I will be using the Google DNS servers, but feel free to use yours:

sudo nano /etc/ppp/pptpd-options

Make sure the following lines are enabled. Note that you have to provide dns AND wins servers for the iPhone to correctly set the dns!



ms-dns 8.8.8.8
ms-dns 4.4.4.4

ms-wins 8.8.8.8
ms-wins 4.4.4.4




Hope it helps
Cheers
Lorenz
 
Comment

south8212

macrumors 6502
Oct 18, 2008
270
0
I would imagine this is not possible without being able to edit the host file on the iPhone.
 
Comment

lorenz meier

macrumors newbie
Oct 6, 2010
2
0
I would imagine this is not possible without being able to edit the host file on the iPhone.

You don't edit anything on the iPhone...this is the configuration of your PPTP server, and it makes sure the right info about the DNS servers is pushed across to the iPhone.
 
Comment

iPhone Addict

macrumors 6502
Jun 18, 2009
326
0
San Francisco, CA
Any way to get this to work if I'm using Win7 VPN server with an iPhone 4 as the client?

I can browse via IP addresses once I connect to my Win7 VPN but cannot browse to any sites with the actual website name.

Thank you.
 
Comment

polychro

macrumors newbie
Jan 23, 2012
1
0
This thread has been going on for 2 years (2.5 now). No solution to this problem? I have no problem with my MacBook Pro but both iphone 4 and iPad2 (both on iOS 5.01) connect to a win xp pptp server but no DNS resolution.
Thanks for any help anyone could provide.
 
Comment

arnault38

macrumors newbie
Mar 6, 2012
1
0
Hi !

I have the same problem and it's impossible to find a solution through the web...

I configure a PPTP connexion between my iPhone and a pfsense router (based on FreeBSD)
I can access to my intranet with the server's Ip but not with name resolution.

I try to find a solution to force dns server on the iphone but it's not a best practice in business environment...

Thanks for your help...
 
Comment

nicloay

macrumors newbie
Jan 4, 2013
1
0
sudo nano /etc/ppp/pptpd-options


ms-dns 8.8.8.8
ms-dns 4.4.4.4

ms-wins 8.8.8.8
ms-wins 4.4.4.4


Lorenz

This solution works!!.
I faced the similar problem, i tried to modify pptpd-options, tried to include this parameters to /etc/pptpd.conf. but anyway clients didn't receive any DNS parameters.

So, if someone faced similar problem, please make sure that you modify correct config files, because, for example, on CentOS you need to modify /etc/ppp/options.pptpd instead of file provided by Lorenz.

To find correct file you can use

Code:
grep ms-dns /etc/ppp/*
Default configs usually contains this parameters (ms-dns and ms-wins) but they are comented.

Hope this helps someone =)
 
Comment

bradhs

macrumors regular
Jun 5, 2010
103
38
What works for me is to fully qualify the computer name. Make sure you have a domain assigned to the VPN connection and you should be fine. Instead of typing mycomputer type mycomputer.mydomain.local (or whatever it is.)

This thread has been going on for 2 years (2.5 now). No solution to this problem? I have no problem with my MacBook Pro but both iphone 4 and iPad2 (both on iOS 5.01) connect to a win xp pptp server but no DNS resolution.
Thanks for any help anyone could provide.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.