iPhone puts the wrong name on my outgoing emails!

Discussion in 'iPhone' started by eyespii, Jul 22, 2011.

  1. eyespii macrumors 6502

    Joined:
    Mar 8, 2008
    #1
    I have several gmail accounts set up on my iphone using exchange. I just realized yesterday that my iphone is attaching the wrong name to all of my outgoing emails.

    For example, I have two email accounts, one personal (xxxxx@gmail.com) and one business (yyyyy@gmail.com), and I'd like to keep different names associated with them both. However, on my iPhone (and iPad actually), emails sent from address yyyyy@gmail.com for some reason will get sent out with the wrong name. The person receiving the email will get:

    From: XXXXX <yyyyy@gmail.com>

    If I send the same email from the gmail webmail using the yyyyy@gmail.com account, the person receiving the email will get:

    From: YYYYY <yyyyy@gmail.com>

    Any idea why this is happening, and how to fix it?
     
  2. Lord Appleseed macrumors 6502a

    Lord Appleseed

    Joined:
    Nov 7, 2010
    Location:
    Apple Manor
    #2
    In the Settings, under Mail Settings you can select each Mail account and set a Name to them.
     
  3. eyespii thread starter macrumors 6502

    Joined:
    Mar 8, 2008
    #3
    There's nowhere to set a name if you have your email accounts set up using exchange.
     
  4. PNutts macrumors 601

    PNutts

    Joined:
    Jul 24, 2008
    Location:
    Pacific Northwest, US
    #4
    I only have one Exchange account it may be different: Settings - Mail, Contacts, Calendars. At the bottom of the mail section there is an option to choose your Default Account. Also, when composing a new e-mail I am able to tap From and select any of the accounts to use as the From address.
     
  5. eyespii thread starter macrumors 6502

    Joined:
    Mar 8, 2008
    #5
    Thanks for the response, but that doesn't solve the issue. The problem isn't that the email is getting sent out from the wrong account, the problem is that the iPhone attaches the wrong name to the account that it's sending the email from (my "personal" name as opposed to my "official work" name).

    In other words, a person receiving email sent from my YYYYY@gmail.com account sees:

    From: "XXXXX" <YYYYY@gmail.com>

    Instead, they should be seeing:

    From: "YYYYY" <YYYYY@gmail.com>

    Sorry if I'm not being very clear with the problem! Any other ideas on what's going on?
     
  6. lifeguard macrumors 6502

    lifeguard

    Joined:
    Nov 25, 2010
    #6
    check your setup on the actual GMAIL settings on the computer. I think you have to change it there

     
  7. eyespii thread starter macrumors 6502

    Joined:
    Mar 8, 2008
    #7
    All emails sent out using the webmail interface of gmail get sent out with the correct name. The only other thing that I could think of was if my iPhone was using the wrong SMTP server to send out emails, but even then there's no way to set a specific smtp server when using exchange.
     
  8. lifeguard macrumors 6502

    lifeguard

    Joined:
    Nov 25, 2010
    #8
    I know this is a pain in the ass but have you removed all the emails and set them all up from the beginning? like you said maybe there is one of the SMTP servers getting caught up. I am kind of at a loss other than that. Good Luck
     
  9. eyespii thread starter macrumors 6502

    Joined:
    Mar 8, 2008
    #9
    Thanks for all the replies everyone - I've solved my issue.

    Apparently, when you have your email account set up on the iphone as an EXCHANGE account, your emails get sent out using the name associated with the google account itself. In other words, the name that you first used when you created that google account. Emails sent from my computer never had that problem because the accounts are configured as IMAP on my computers.

    Once I changed the name on the account itself, emails sent out from my iphone now get sent with the correct name!
     

Share This Page