iPhone randomly disconnects from Wi-Fi

Discussion in 'iPhone Tips, Help and Troubleshooting' started by No5tromo, Feb 17, 2012.

  1. No5tromo, Feb 17, 2012
    Last edited: Feb 26, 2012

    No5tromo macrumors regular

    No5tromo

    Joined:
    Feb 17, 2012
    #1
    -Solved-

    A couple of weeks ago I bought a brand new, unlocked iPhone 3Gs to replace my iPhone 3G. My 3G had a few problems given that it had been broken and manually re-assembled using some replacement parts.

    One of the problems I was hoping to get fixed was the random disconnects from the wi-fi I was having, but unfortunately that was the only thing that stayed the same. The problem is more persistent when I return from the lock screen, which I understand that it automatically disconnects while locked to save power, but it often seems to refuse for quite some time to re-connect even when I try to manually do so from the settings. It could also happen -less frequently- at any random time, while using the phone, resulting to swap to data plan usage without me being aware, emptying all of my prepaid credits. Also, if I start downloading/updating an app and I stop using the phone until it locks, chances are it will automatically swap from wi-fi to carrier data usage.

    Here's a few more details that might be helpful:
    I got a Netgear DG834G v4 wireless router, updated to the latest firmware. All other devices in the house, including my brother's iPhone 4, connects to the wi-fi with no any issues. After endless googling and finding people with the exact same issue I tried the following things but none of them worked:
    Restarted the router
    Restarted the device
    Changed wi-fi security from WEP to WPA2 (AES encryption)
    Reset all network settings
    Completely restored iPhone

    It's not a big place where I live, yet when I am not in the living room, where the router is, I seem to get 2 lines of signal instead of 3 (full). My laptop always has full signal where my iPhone seems to generally struggle. When I got full signal the wi-fi seems to be doing better, yet I'm not sure that signal strength is related to my issue.

    If you know anything about this problem, any advice would be appreciated. Could it be a compatibility issue with the specific router? (haven't tried how it responds in other networks tbh) Could it be that my device is faulty? Could it be an iOS 5 issue? Could it be an ISP issue? Given that it resembles the exact problem I had with my previous iPhone but no one else who uses this wi-fi seems to have any problems on any device, I'm out of ideas.
     
  2. RodThePlod macrumors 6502a

    RodThePlod

    Joined:
    Sep 7, 2005
    Location:
    London
    #2
    If you had the same problem with the previous iPhone, then it's not a faulty device. iPhone 4 had an updated and improved radio over the 3/3G which explains why your brother's phone can maintain a good connection.

    You've looked at many things already, but you don't mention relocating the router. I would definitely look at that; ensure that the router isn't positioned too close to anything that might cause interference like speakers or large metal objects/surfaces. Also, make sure the router is positioned high up and not tucked away somewhere.

    Some routers also allow you to change either the wireless band, or the wireless channel. Does yours? If so, you might want to initially change the wireless channel to see if it makes a difference.

    Good luck!

    RTP.
     
  3. Makman8 macrumors member

    Makman8

    Joined:
    Nov 22, 2011
    Location:
    Noho CA
    #3


    Might be time for a new router or if its only a year old might be a faulty router. I do know some routers the older they get the more susceptible they are to wifi connection issues and random signal drops. I know if I ever have a signal issue most of the time it is solved with just a simple router upgrade. You can get some nice "refurbs" (most of the time they are brand new!) on compusa for a steal! Good luck and hope you find a solution.

    here are 2

    http://www.compusa.com/applications/SearchTools/item-details.asp?EdpNo=1818655&CatId=2668

    http://www.compusa.com/applications/SearchTools/item-details.asp?EdpNo=5569261&CatId=2668
     
  4. No5tromo thread starter macrumors regular

    No5tromo

    Joined:
    Feb 17, 2012
    #4
    Thanks for the answers. I'm pretty sure that it's the router. Not that the 3Gs has a great wi-fi reception but this router model has been problematic all along (like any Netgear product I've bought tbh). I had similar issues with my HP laptop before I updated the firmware.

    I don't know if this could be an interference with the wireless phone's base which is right next to it, but unfortunately I got no option to move either around because the house has only got one functional phone jack, put in an inconvenient place. I got the router placed nonetheless as well as possible, high up, antenna pointing up, turned vertically (it came with a special base) so I avoid overheating.

    I will also try changing the channel and see if that helps, it's on 11 atm. As for the band, I looked around a bit and I don't seem to find an option to change it.

    If nothing works, maybe it's time for a new router.
     
  5. normanbates macrumors regular

    Joined:
    Aug 24, 2011
    #5
    I have always had my router on channel 6, it's also a net gear (the most reliable I've had) like all of my routers have been.

    Try channel 6
     
  6. RodThePlod macrumors 6502a

    RodThePlod

    Joined:
    Sep 7, 2005
    Location:
    London
    #6
    The channel that gives the best performance depends on what's going on in your immediate vicinity. If your neighbours on either side of you are using channel 6 then it's probably not the best channel for you to use as it may be 'noisy' and could result in drop-outs, etc.

    Some routers will try to 'auto seek' to get the least congested channel, but if your doesn't have that feature it'll come down to trial and error while you manually set and use each channel for a while attempting to find the best one.

    Cheers,

    RTP.
     
  7. No5tromo, Feb 18, 2012
    Last edited: Feb 18, 2012

    No5tromo thread starter macrumors regular

    No5tromo

    Joined:
    Feb 17, 2012
    #7
    I'm under the impression that routers which come pre-configured from ISPs over here are all set to channel 6, but I could be wrong. I set this router manually with the help of a tech guy over the phone and he suggested I set it to channel 11.

    I read on another forum that channel 1 is the least likely to be affected by interference... I don't know if this is true, but I got in on channel 1 for a few hours now and hasn't disconnected yet so, fingers crossed, this might actually solve my problem :D

    BTW does any of you know why everyone seems to be using one of the three channels 1,6 or 11? What's wrong with the rest of them? I just counted 17 wi-fi signals from apartments around, sometimes there are more, if we all use one of these 3 channels no wonder it causes problems, but everyone seems to suggest these ones...
     
  8. Dviper27 macrumors member

    Joined:
    Feb 18, 2012
    #8
    Could be a faulty router
     
  9. No5tromo thread starter macrumors regular

    No5tromo

    Joined:
    Feb 17, 2012
    #9
    Update:

    Changing to channel 1 didn't fix the problem. I downloaded a programme called inSSIDer and it tracks all wi-fi signals in range and even shows you what channel each one is on.
    The area I live is highly congested, here's an idea of how it looks (there is more left to scroll down).

    [​IMG]

    I figured that channel 13 would be the best choice, but for some reason one of the laptops in the house (the newest one..) was not compatible with the channel which is weird because there is a channel 13 restriction only in America, so I returned back to channel 11.

    It is very likely that all this congestion is causing net problems and I guess only a dual band router would fix it (hoping that all devices are comptabile with the 5 GHz band, something I haven't looked into...)

    For now I will have to settle with being able to download big apps only in the living room where I get good signal and there is less risk of losing connection on my iPhone, or I will just download them through iTunes...

    It's a shame really, I payed 354 € for a brand new 3Gs hoping that I could enjoy careless wifi usage... it's still an awesome phone but I'm kinda bugged.

    P.S.
    To answer my question why everyone is using channels 1, 6 and 11, it's because by doing so, you avoid overlapping with neighbouring channels, however though these channels would make sense in American where the legal channels are 1-11, I don't know why we picked it up in Europe as well, we could use channels 1, 5, 9 and 13 that are legal and won't overlap so we could avoid extra congestion... It's weird though that some devices bought in Europe are not compatible with channel 13, My 2008 HP laptop and my iPhone 3Gs are.
     
  10. No5tromo, Feb 25, 2012
    Last edited: Feb 25, 2012

    No5tromo thread starter macrumors regular

    No5tromo

    Joined:
    Feb 17, 2012
    #10
    Update:

    Problem is still there, after trying a million things, a Netgear tech guy suggested I completely turned off wireless security... and TADA! Now everything works as it should :rolleyes: No disconnections, no nothing, in fact even when I return from lock screen, the swap from the antenna to Wi-Fi is so fast that I can barely notice it.

    This leaves us with a couple of problems though....
    A. If I leave my wi-fi unsecured I will soon become the free hotspot of the block.
    B. It doesn't sound like a normal behaviour at all, which means that something is not working correctly.

    Next step... I will try to determine whether the problem is on my iPhone or on the router.

    Good luck to me :mad:
     
  11. No5tromo thread starter macrumors regular

    No5tromo

    Joined:
    Feb 17, 2012
    #11
    Solution:
    Updated the firmware on an ISP giveaway Thomson router (by Technicolor aka Alcatel and Speedtouch). Replaced the Netgear one.

    Conclusion:
    Another NETGear fail. Not sure what exactly caused the whole thing, my guess is it was a problem with the encryption since the problem would go away if I disabled the wireless security.
     

Share This Page