iPhone Randomly Reset Itself Almost to Factory Settings

Discussion in 'iOS 7' started by MacPro1984, May 16, 2014.

  1. MacPro1984 macrumors newbie

    Joined:
    May 16, 2014
    #1
    iPhone 5 running iOS 7.0.2 jailbroken. Jailbroken but has been very stable forever, and I only installed a few non-invasive packages.

    I was using my iPhone for testing my app with Xcode, and my app suddenly started crashing whenever I launched it. Puzzled, I tried respringing using a new Cydia tweak I had installed recently but had never used that adds a respring button to Control Center (I think it was just called "Respring" on Cydia). Nothing happened after I pressed it 5 times, so I just rebooted.

    When my phone booted up, it gave me the welcome screen as if my iPhone were new. But it still had my passcode, so it obviously wasn't actually at factory defaults. I went through setting it up to see what of my system remained, but it froze every time I got to the step asking whether I want to send diagnostics to Apple (I tried both options). I guess the OS is corrupted, and I'll have to reinstall later. What could have happened?

    One more thing: Before my app started crashing, someone typed "sudo rm -rf" on my MobileTerminal as a joke but didn't run it, and I quit MobileTerminal. The system has no sudo command, so it couldn't have run anyway. But maybe I'm missing something?
     
  2. afsnyder macrumors 65816

    Joined:
    Jan 7, 2014
    #2
    Umm... obviously Jailbreaking caused this issue.
     
  3. Xenomorph macrumors 65816

    Xenomorph

    Joined:
    Aug 6, 2008
    Location:
    St. Louis
    #3
    Really? 7.0.2?

    You're running an old, cracked copy of iOS, full of dozens of known bugs and terrible security flaws.

    Put your device into DFU mode, RESTORE it, and try to learn what a "harmless" jailbreak actually involves.
     

Share This Page