iPhone refuses to download BSD subsystem.

Discussion in 'Jailbreaks and iOS Hacks' started by TheD1amond, Feb 19, 2008.

  1. TheD1amond macrumors newbie

    Joined:
    Feb 19, 2008
    #1
    I activated and jailbroke my phone using the ziphone 2.4 method here.

    http://www.iclarified.com/entry/index.php?enid=656

    My next step was to try and download the BSD subsystem it just said downloading package and nothing happened.

    I rebooted the phone and re-installed the installer, then tried to download the BSD installer again with the same result.

    I tried re-nstalled community sources. same result.

    So started over from step 1.

    Got as far as trying to download th eBSD subsytem. Now i get an error that says "MAin script execution failed"

    I've been arsing about with the iphone for 2 weeks now and I'm very close to firing it in the skip. 90% of the tutorials I try don't do what they say on the tin.

    Can anyone help?
     
  2. Akitakoi macrumors regular

    Akitakoi

    Joined:
    Jan 31, 2008
    #2
    I've been getting that message alot lately. Make sure your in WiFi, your set to never and do a reboot.

    Another thing to check , go to uninstall and get rid of everything and reboot and try again.

    If all else fails there is always restore and start over.
    Good luck
     
  3. TheD1amond thread starter macrumors newbie

    Joined:
    Feb 19, 2008
    #3
    I've restored and strarted over many times.

    Have tried to install community sources and I get the error "Package download failed (null)!"

    I'm using wi-fi. Not sure what you mean when you say "Make sure your in WiFi, your set to never and do a reboot."
     
  4. AHDuke99 macrumors 68020

    AHDuke99

    Joined:
    Nov 14, 2002
    Location:
    Charleston, SC
    #4
    I got that a lot after i restored and rejail broke to get youtube to work. i'm waiting till the SDK now in a week or so. Not worth having a half functional phone and a useless installer. plus, the apps are not working all that well on 1.1.3 and most of them are useless outside of solitare, and audio amplifier, and mobilechat which can no longer connect in 1.1.3.
     
  5. dsgalit macrumors member

    Joined:
    Nov 13, 2007
    #5
    Make sure you clear your download queues in installer before trying to download anything else... One more thing, when you restore make sure you start out as a new phone and do not restore from backup because restoring from backup brings back everything you had on your phone prior to the restore...
     
  6. TheD1amond thread starter macrumors newbie

    Joined:
    Feb 19, 2008
    #6
    Yes, I've done all this. There must be something I've overlooked.
     
  7. TheD1amond thread starter macrumors newbie

    Joined:
    Feb 19, 2008
    #7
  8. Zanevalon macrumors newbie

    Joined:
    Jun 25, 2007
    #8
    im having the same issuse, i thought maybe my phone was broken but meh....iunno i guess i'll jus have to wait for the SDK to be released..
     
  9. TheD1amond thread starter macrumors newbie

    Joined:
    Feb 19, 2008
  10. xUKHCx Administrator emeritus

    xUKHCx

    Joined:
    Jan 15, 2006
    Location:
    The Kop
    #10
    Software development kit. Basically it allows developers to write software for the iPhone. Will mean a lot of applications will appear for the iPhone.
     
  11. TheD1amond thread starter macrumors newbie

    Joined:
    Feb 19, 2008
    #11
    Let me guess. Another miracle fix that sends me round in circles for another 30 hours before I bang my head off the wall, look for answers on umpteen forums and still get nowhere? Why do I need a software development kit anyway?

    I can't understand how so many people have sorted out their iPhone so easily and I get nowhere. It's not like I can't follow instructions.
     
  12. dsgalit macrumors member

    Joined:
    Nov 13, 2007
    #12
    go to sources - edit - add then type "ride4.org/shai.xml", after it loads go into sources under "Categories" there you'll find "All Sources" install that, it has most of the repos you'll ever need..
     
  13. tomass macrumors newbie

    Joined:
    Dec 14, 2007
    #13
    just click on: Sources, then refresh.

    The download should install fine after the refresh.
     
  14. TheD1amond thread starter macrumors newbie

    Joined:
    Feb 19, 2008
    #14
    lol! this is what everyone keeps saying to me.

    The phone attempts to refresh sources, but returns an error. "Could not refresh sources!"
     
  15. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #15
    Solution has been explained in other threads. You need to use terminal and run some commands.
     
  16. TheD1amond thread starter macrumors newbie

    Joined:
    Feb 19, 2008
    #16
    link?
     
  17. nataraja macrumors newbie

    Joined:
    Feb 26, 2008
    #17
    Same issue on my 16Gb touch

    hi,

    I have the same issue.
    Thanks for the link to the terminal stuff solution ...
     
  18. swoosh0217 macrumors 6502a

    swoosh0217

    Joined:
    Nov 20, 2007
    Location:
    NW
    #18
    Go to "Installer" and go to "Uninstall". Uninstall the Installer and it will automatically re-install your installer. Turn off your phone and reboot. Go back to Installer and now install some packages. That should take care of your problem.
     
  19. MacCurry macrumors 6502

    Joined:
    Aug 28, 2006
    #19
    What I found is that after running ZiPhone 2.4, go into settings (on the iPhone) and turn off Wifi. After that turn off the iPhone and then turn it on, then try re-installing BDS Subsystem and OpenSSH.
     
  20. MacGirrl macrumors newbie

    Joined:
    Feb 27, 2008
    #20
    iphone receiving error message

    hello all. i am having the same exact problems since yesterday. i cannot refresh. keep getting the error message '"Package download failed: null", and "main exectution" error. i cant download anything.:confused: i jailbroke,unlocked,and activated my phone to t-mobile using the ziphone. i have a. iphone 1.1.3. i have tried every technique that you guys have suggested. if i restore my phone and start all over, do i reinstall the ziphone to redo the jailbreak, etc? then once its reonstalled, install hte BSD first? Any suggestions? :confused:
     
  21. swoosh0217 macrumors 6502a

    swoosh0217

    Joined:
    Nov 20, 2007
    Location:
    NW
    #21
    No you don't restore for this small problem. Ive had this issue many times and I keep telling everyone... uninstalling and reinstalling the installer works!

    1. Go to Uninstall, select the installer app and Uninstall it. This will automatically reinstall your installer.

    2. Press home button, turn off your phone and reboot.

    3. Go back to installer and now try installing the BSD package.
     
  22. gadgetdad macrumors 6502a

    gadgetdad

    Joined:
    Sep 10, 2007
    Location:
    On my iPhone
    #22
    I used ziPhone 2.4 to jailbreak my 1.1.4 16 gigger. Yesterday I had the same downloading problem so when I got home I simply started up ziphone and jailbroke again. Perfection now. Everything works and can install from installer.
     

Share This Page