iPhone repeatedly disconnects/reconnects

hitenders

macrumors newbie
Original poster
Jun 6, 2008
4
0
Hello folks,

I have this strange problem when I connect my iPhone to the PC. It seems to repeatedly disconnect/reconnect to the computer sometimes. At first, I thought it was the dock causing the problem, but it happens also when the USB cable is directly plugged into the iPhone.

It started first on another USB hub which is not USB 2.0 supported, I shifted it to another USB port which in fact USB is 2.0 supported, everything was fine for a week then it started doing it on this port too, happened twice for a span of 5 seconds.

I know nothing is wrong with the USB cable as this does not happen when I connect it to the wall dock.

I've reinstalled iTunes but to no avail, I'm guessing it's my crappy PC.

It's stopped happening on both the USB ports now but it concerns me since the last time it happened to me on the first USB port, I got an error which led to all the songs from my iTunes disappear.

Any help or info on this will be greatly appreciated,

Cheers.
 

budfoot

macrumors regular
Jul 1, 2008
249
122
Boston, MA
Same thing is happening to me on my macbook...

I'm on my 4th iPhone.

I don't think it's the phone. I can't use some external drives (aka, Time Machine backups) on the port that the iPhone went funky on now.

Try other USB periphs, i'd bet you're having the same problem.

iPhone seems to have fried at least 1 USB port on my system?
 

budfoot

macrumors regular
Jul 1, 2008
249
122
Boston, MA
Now that i've searched around some more, seems to have something to do with iPhone crashing the usb2.0 driver? I've a genius bar appt tomorrow night, so we'll see what happens.
 

budfoot

macrumors regular
Jul 1, 2008
249
122
Boston, MA
Did anyone find a solution to this?
Yes yes yes.

It's push/3g. If you disable push, it stops. If you disable 3g, it stops.

I took both my mac and the phone to the apple store on Boylston. Couldn't repro it. I finally realized i had turned off push, turned it back on, and the thing went nuts.

They are wanting to replace the USB port. His reasoning was he plugged my phone into another MBP and it didn't do it (makes sense to me).

So, i couldn't leave my MB, i had to go to Reading England, but when i get back, i'm going to drop it for a pro-care appt.
 

glxyjones

macrumors regular
Jun 29, 2007
200
27
Any news on this? I disabled push, 3g, even went into airplane mode and nothing helped. I know it's not the cable because it worked fine on my old iphone.

I've tried connecting it through my iMac keyboard, my usb hub, and directly into the computer... nothing works.
 

budfoot

macrumors regular
Jul 1, 2008
249
122
Boston, MA
Well, of sorts...

I've been using my phone now for a couple months (has it been that long?)... i've noticed a few things..

There are certain APPS that will cancel syncs, don't ask me how or which ones, but i've noticed that when i have restored my iphone to blank, it'll sync music and stuff all day. As soon as i start putting apps on it, it starts disconnecting/reconnecting.

Also, i've been using the right USB port of my MBP, the one furthest away from the power jack. I have yet to have the time to drop my MBP off at the genius bar to have them replace the usb port on the left side.

There is definitely something funky. And it's gotten downright intolerable since 2.0.2... we'll see if 2.1 fixes it.
 

bjobes

macrumors regular
Jul 21, 2008
168
0
My 3g started this after updating to iTunes 8. Device manager shows the iPhone as a imaging device which was fine. I'd drill down and reinstall the device usb driver and it would work.

No longer does that anymore. The driver now says access denied.
 

monstabyte

macrumors newbie
Jun 21, 2009
1
0
Hi Guys - just stumbled on this thread via Google and thought I would take the time out to offer you my solution:

I had the same problem and thought it was a number of things (USB Port/IPhone/Cable/etc...) - however resetting my iphone didn't help and neither did restarting my PC.

What you need to do is actually POWER DOWN your PC. Not just restart it. Actually switch it off! Then unplug it from the power socket and - whilst unplugged - hit the "on" button of your PC a few times within a good 30 seconds (i.e. give it a few secs or this might not work).
The idea is that all the little bits of "leftover power" on your mainboard need to discharge.

Having done that simply plug the PC back in, boot up, and all should be restored to normal.

This trick OFTEN works when USB devices are playing up and I have no real idea why except for that it obviously has something to do with the wrong kind of electrical charge building up on the USB ports.

I have never experienced it with laptops but with heaps of component-built PCs.

Hope it helps - it worked for me and my iPhone 3G ...

cheers
monstabyte
 

PNutts

macrumors 601
Jul 24, 2008
4,839
347
Pacific Northwest, US
This happens whenever I use the same USB port as a slow (1.0) device, i.e., keyboard, keeping in mind it is difficult to know which exernal ports share the same internal hub (they are typically pairs).

I solved the problem by unplugging all the USB devices I could, make sure the issue went away, and then plugged them back in one by one (and moving the iPhone when necessary).
 

MattMorgan105

macrumors newbie
Oct 15, 2011
1
0
This worked for me!!

I have an iPhone 4. This problem drove me nuts. Glad I found this post. Thanks budfoot.

Yes yes yes.

It's push/3g. If you disable push, it stops. If you disable 3g, it stops.

I took both my mac and the phone to the apple store on Boylston. Couldn't repro it. I finally realized i had turned off push, turned it back on, and the thing went nuts.

They are wanting to replace the USB port. His reasoning was he plugged my phone into another MBP and it didn't do it (makes sense to me).

So, i couldn't leave my MB, i had to go to Reading England, but when i get back, i'm going to drop it for a pro-care appt.
 

Omnirai

macrumors member
Jan 8, 2012
53
0
Antwerp
Sorry to be gravedigging.. But bumped on this thread while using google.

I have 2x iPhone 4s, both same model (but way different manufacturing date).

The first iPhone works perfectly fine.

The second iPhone shows this disconnect/connect loop while hooking it up in both USB ports on my rMBP 13" haswell.

Connecting the 'problem' iPhone to another computer doesn't give me this error, so I tried hooking it up to my rMBP again.

Result: left side USB port still reproduces the error, now the right side USB works fine with the iPhone..

Anyone got any idea whats actually going on?
 

byron_hinson

macrumors 6502
Jun 3, 2003
295
9
Sorry to be gravedigging.. But bumped on this thread while using google.

I have 2x iPhone 4s, both same model (but way different manufacturing date).

The first iPhone works perfectly fine.

The second iPhone shows this disconnect/connect loop while hooking it up in both USB ports on my rMBP 13" haswell.

Connecting the 'problem' iPhone to another computer doesn't give me this error, so I tried hooking it up to my rMBP again.

Result: left side USB port still reproduces the error, now the right side USB works fine with the iPhone..

Anyone got any idea whats actually going on?
Bringing this one up again. Just replaced my iMac with a new iMac 5k and now have this issue now and again. Has anyone got a solution.
 

biver

macrumors newbie
May 23, 2010
9
0
Jailbroken iPad Air on 8.1.2 - Safemode Solves problem

I just used Activator to assign a gesture for restart springboard in Safe Mode.

After re-springing into Safe Mode the connect/disconnect stopped.
 

13astion

macrumors newbie
Dec 5, 2010
27
31
Sorry to be gravedigging.. But bumped on this thread while using google.

I have 2x iPhone 4s, both same model (but way different manufacturing date).

The first iPhone works perfectly fine.

The second iPhone shows this disconnect/connect loop while hooking it up in both USB ports on my rMBP 13" haswell.

Connecting the 'problem' iPhone to another computer doesn't give me this error, so I tried hooking it up to my rMBP again.

Result: left side USB port still reproduces the error, now the right side USB works fine with the iPhone..

Anyone got any idea whats actually going on?
Just discovered the same thing - was driving me nuts for months!

MBP 15" Retina (late 2013), and whenever I'd connect my iPad to the left USB port, it would flip out on disconnects. My iPhone 5s would work just fine, though.

Thing is, I have another MBP for work (same model) and it does the same thing.

As soon as I switched the the right USB port, all was well.

Methinks this was an Apple build problem....
 

soum91

macrumors newbie
Oct 31, 2014
29
7
Nudging the USB cable worked for me. Don't push it fully to the port, push it gradually see at what point it detects the idevice. This worked from me.
 
  • Like
Reactions: sideecm

TinHead88

macrumors regular
Oct 30, 2008
192
25
I had this problem and it was very odd in the way it suddenly appeared. After much googling with no definitive answers I ended up fixing it by slightly pressing (and bending) the hollow side of the USB plug to make sure it grips onto the connectors properly. This has completely fixed it for me. I would suggest anyone with this problem should investigate cabling, especially how well the USB plug sits inside the USB port of the computer.
 

aditya_kamble

macrumors newbie
May 27, 2016
1
0
Hello folks,

I have this strange problem when I connect my iPhone to the PC. It seems to repeatedly disconnect/reconnect to the computer sometimes. At first, I thought it was the dock causing the problem, but it happens also when the USB cable is directly plugged into the iPhone.

It started first on another USB hub which is not USB 2.0 supported, I shifted it to another USB port which in fact USB is 2.0 supported, everything was fine for a week then it started doing it on this port too, happened twice for a span of 5 seconds.

I know nothing is wrong with the USB cable as this does not happen when I connect it to the wall dock.

I've reinstalled iTunes but to no avail, I'm guessing it's my crappy PC.

It's stopped happening on both the USB ports now but it concerns me since the last time it happened to me on the first USB port, I got an error which led to all the songs from my iTunes disappear.

Any help or info on this will be greatly appreciated,

Cheers.

I am also facing the same problem and I knew it's nothing to do with the cable. Following thing works for me:
1. I disconnect the USB from my MacBook and from iPhone connection port.
2. Just assuming, there might be some residual current, I touch both the ports of the cable to wall or something to drain out if anything is there inside the cable.
3. Try 2-3 times and this works for me.

In case that doesn't work, I generally add 2 more steps:
1. After doing step 1 and step 2, I connect the USB cable to my MacBook and connect the other port to wall.
2. Now disconnect the cable and touch both cable ports to wall.
3. And lastly, connect iPhone port only and touch the USB part to the wall.
4. And then try to connect.

Some random steps help me connect, still can't figure what could be the exact case!!
 

dude-with-iphone

macrumors newbie
May 30, 2016
1
0
Hello folks,

I have this strange problem when I connect my iPhone to the PC. It seems to repeatedly disconnect/reconnect to the computer sometimes. At first, I thought it was the dock causing the problem, but it happens also when the USB cable is directly plugged into the iPhone.

It started first on another USB hub which is not USB 2.0 supported, I shifted it to another USB port which in fact USB is 2.0 supported, everything was fine for a week then it started doing it on this port too, happened twice for a span of 5 seconds.

I know nothing is wrong with the USB cable as this does not happen when I connect it to the wall dock.

I've reinstalled iTunes but to no avail, I'm guessing it's my crappy PC.

It's stopped happening on both the USB ports now but it concerns me since the last time it happened to me on the first USB port, I got an error which led to all the songs from my iTunes disappear.

Any help or info on this will be greatly appreciated,

Cheers.
[doublepost=1464642736][/doublepost]Its definitely a usb conflict thing. Not sure who posted it, but someone suggested, and I tried removing all my USB devices one by one until I found the problem and it worked. My conflict was with a Microsoft mouse (?!?) and my phone. I disconnected the mouse, plugged in the phone, phone worked fine. I reconnected the mouse, mouse worked fine. Everything works fine together now. The computer obviously rerouted the mouse in the USB software afterwords, but my totally uneducated guess is that there seems to be some issue rerouting the phone.
 

jckjck

macrumors newbie
Jan 6, 2017
1
0
Signed up purely to share my solution:

Pull the USB connection out slightly - stopped mine from connecting/disconnecting instantly, and iPad shows as charging...
 

Bobbykoa

macrumors newbie
Jun 27, 2017
1
0
Lihue
Yes yes yes.

It's push/3g. If you disable push, it stops. If you disable 3g, it stops.

I took both my mac and the phone to the apple store on Boylston. Couldn't repro it. I finally realized i had turned off push, turned it back on, and the thing went nuts.

They are wanting to replace the USB port. His reasoning was he plugged my phone into another MBP and it didn't do it (makes sense to me).

So, i couldn't leave my MB, i had to go to Reading England, but when i get back, i'm going to drop it for a pro-care appt.

What is push/3g? And how do you disable it?
[doublepost=1498581880][/doublepost]What is push/3g? And how do you disable it?
 

snowstrum

macrumors newbie
Aug 23, 2017
1
0
Hello folks,

I have this strange problem when I connect my iPhone to the PC. It seems to repeatedly disconnect/reconnect to the computer sometimes. At first, I thought it was the dock causing the problem, but it happens also when the USB cable is directly plugged into the iPhone.

It started first on another USB hub which is not USB 2.0 supported, I shifted it to another USB port which in fact USB is 2.0 supported, everything was fine for a week then it started doing it on this port too, happened twice for a span of 5 seconds.

I know nothing is wrong with the USB cable as this does not happen when I connect it to the wall dock.

I've reinstalled iTunes but to no avail, I'm guessing it's my crappy PC.

It's stopped happening on both the USB ports now but it concerns me since the last time it happened to me on the first USB port, I got an error which led to all the songs from my iTunes disappear.

Any help or info on this will be greatly appreciated,

Cheers.
I just had the same problem, tried different USB port to no avail, tried re-booting both phone and computer, no help, then changed to the cable I usually use, instead of one that my wife was using with her i-phone (same phone) and the different cable stopped the problem. Connected immediately, did the automatic synch. Got the idea from some of the replies below, so thanks to those who came up with it. snowstrum
[doublepost=1503521417][/doublepost]
I just had the same problem, tried different USB port to no avail, tried re-booting both phone and computer, no help, then changed to the cable I usually use, instead of one that my wife was using with her i-phone (same phone) and the different cable stopped the problem. Connected immediately, did the automatic synch. Got the idea from some of the replies below, so thanks to those who came up with it. snowstrum
I'm elaborating on my reply, which wasn't fully inclusive. The computer is a PC. The "same" phone meant same model, not the same phone I was trying to connect to my PC. I think there may have just been a small defect in the contacts, or perhaps the same model phones had some slight configurational changes from time to time in the cable jacks?? Anyhow, hope this helps a few out there. snowstrum
 

Inos74

macrumors newbie
Sep 30, 2017
1
0
I got the same problem... I fixed it easy... Use the orginal Iphone Cable if you use a cheap one from the internet.
Instantly the problem was solved. I hope this helps a lot of people.
I still use the cheap cable for charging in power socket, does the job for that
 

sideecm

macrumors newbie
May 29, 2018
1
0
Nudging the USB cable worked for me. Don't push it fully to the port, push it gradually see at what point it detects the idevice. This worked from me.
works for me as well. thank god resolved it without doing anything complicated
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.