iPhone restore stuck at 'Verifying Restore with Apple'

Discussion in 'Jailbreaks and iOS Hacks' started by az988, Sep 21, 2010.

  1. az988 macrumors member

    Dec 26, 2009
    Hi All,

    I was trying to help a friend of mine was trying to unlock his AT&T 3gs phone. His phone was only upgraded to 4.01 (nothing later). I thought the best thing to do would be to reinstall 4.01 firmware, go to jailbreakme.com, and then install ultrasn0w through Cydia. Whenever I try to restore 4.01 firmware, I get stuck on 'Verifying Restore with Apple', which eventually leaves me with 'Error 3194'. I even tried putting the phone in both recovery and DFU modes before trying to restore. Any other ideas would be very much appreciated!

    Btw, no matter what I do, I can't get out of recovery mode -- I can only get to DFU mode.
  2. outz macrumors 6502

    Jul 17, 2007
    4.01 isn't being signed any longer by apple.

    did he backup the shsh for that version? that's the only way you will be able to restore the older version. if he didn't back up the shsh (signature file?) back when apple was signing 4.0.1... it's too late to do it now.

    you will just have to jailbreak his current install.
  3. az988 thread starter macrumors member

    Dec 26, 2009
    Thanks for the reply! Wow that really blows... We don't have a backup of the signature file. :/

    I also tried to restore with a Snowbreeze hacked 4.0 ipsw (after putting the iphone in DFU mode). I'm assuming that returned error 1600 because we're trying to revert to an older OS version.

    Unfortunately jailbreaking his existing firmware showed some very weird behavior, and the ultrasn0w unlock didnt even work. Now I can't even get back to that faulty firmware (stuck in recovery or dfu mode)... I guess he's just gonna have to install 4.1 and wait for another jailbreak/unlock to come along.

  4. outz macrumors 6502

    Jul 17, 2007
    im not sure if this will work in your case, but i was able to kick my phone out of recovery mode using the program 'tiny umbrella' (which is also what you can use to backup your shsh)

  5. az988 thread starter macrumors member

    Dec 26, 2009
    Is jailbreakme.com the only way to jailbreak 4.01 firmware?
    I will give TinyUmbrella a try, thanks again!
  6. mlts22 macrumors 6502a

    Oct 28, 2008
    For the iPhone 4, jailbreakme is the only way.

Share This Page