iPhone restoring 3.1.2 firmware. Tired everything, Nothing working

Discussion in 'iPhone Tips, Help and Troubleshooting' started by spooks, Feb 10, 2010.

  1. spooks macrumors newbie

    Joined:
    Feb 11, 2009
    #1
    So I recently Jailbroke my iphone 3GS and downloaded an app off via Cydia that messed up my phone. Since downloading it, my iphone wont boot. It gets stuck on the boot screen and then just turns off after a few seconds.

    I want to restore it to with the 3.1.2 firmware (which I have), but I am not able to do it with iTunes because as you know apple no longer signs off on 3.1.2. When I put it in DFU mode and try to restore it to 3.1.2 I get the message: "This device is not eligible for the requested build"

    I only had my phone jail broken for about 5 mins before this problem happened so I didnt get a chance to check if I had the ECID SHSH file saved via Cydia, but because I cant restore through apple, I am assuming I don't or it didn't work (althrough I did click the "Make my life easier" button when setting up Cydia.

    So I tried this tutorial to bypass the ECIS SHSH signing phase: http://www.hackthatphone.com/3x/local_ecid_shsh.html

    But when i got to the stage where you get the SHSH file using Umbrella, I got the message "Could not get your ECID SHSH file for that model/version:sorry"

    Next I tried this tutorial: http://www.ihackintosh.com/2010/02/downgrade-iphone-3gs-os-3-1-3-to-3-1-2-with-cydia-shsh/

    I replaced the hosts file with my new custom one, but when I tried to restore using my 3.1.2 firmware, I am still getting the message: "This device is not eligible for the requested build"

    Am I missing a step somewhere? Anyone know how to fix the problem with Umbrella? any other solutions?
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    You can't fix it. Apple will not release your shsh's for 3.1.2 any more.
    See if you can use the new pwnage tool and upgrade to custom 3.1.3 firmware.
     

Share This Page