iPhone (Rev A / EDGE) Not able to make or receive calls

Discussion in 'iPhone Tips, Help and Troubleshooting' started by LimeiBook86, Jul 26, 2008.

  1. LimeiBook86 macrumors 604

    LimeiBook86

    Joined:
    May 4, 2002
    Location:
    Go Vegan
    #1
    Hello everyone,

    Recently my phone has been acting very strange. It's updated with the 2.0 software and has not been hacked in anyway. My phone can not make, or receive calls, period. If I am in my house with full service and I call from my landline phone, the call will go directly to voicemail. If I try and make a call from my phone (again when I have full service) it says "Call Ended" and gives me three beeps. Also I am having a really tough time sending and receiving text messages and voicemail's. Notifications of voicemails seem to be delayed by hours, text messages take a dozen tries to send (if it even goes through). The iPhone seems to be out of warranty, so of course it's messing up. :rolleyes:

    I'm going to try restoring the phone using iTunes, I've tried resetting it and turning it off but nothing seems to help. Any advice or help resolving this problem would be great. Thanks!

    Update: Thankfully the issue was resolved by a complete restore, however I'm still going to contact AT&T about the service issues in my area.
     
  2. operator207 macrumors 6502

    Joined:
    Jul 24, 2007
    #2
    Good to hear that you got it fixed.

    I had the same problem, but it was after I jailbroke the phone. I selected "activate phone" and it did what yours did. I had to re-restore the phone, deselect "activate phone" and it worked after that.

    I am wondering if your phone was deactivated somehow. Either by AT&T, or by something on the phone that messed up.
     
  3. batu544 macrumors newbie

    Joined:
    Mar 5, 2008
    #3
    HI,
    I am also facing this problem for last 1 day. Whenever I am trying to call from my landline or some other phone, I am not able to call it. also I am not able to make any call. Its simply showing call ended. But sometime I am able call if I restart the Iphone, after closing the phone app then the same problem "call ended" .

    I did twice complete restore, but still the same problem..


    Can anyone help me on this ...
     

Share This Page