iphone safari problem

Discussion in 'iPhone' started by jordan eff, Mar 24, 2009.

  1. jordan eff macrumors regular

    Joined:
    Dec 17, 2008
    #1
    Hi

    I have an iphone 3g on O2 pay as you go and recently just about everytime i try to load a page on safari it always says the network was lost and doesnt load, but i look and i am getting a full 3g signal constantly, I even tried restoring the iphone today as it was also getting a bit laggy and still it has trouble in safari

    anyone shed any light on this

    thanks
     
  2. Resist macrumors 68030

    Joined:
    Jan 15, 2008
    #2
    I am not happy with Safari on the iPhone at all. It is very slow even through my home WiFi network. Not to mention how hard it is to read and using the zoom function seems to slow it down even more. I'd rather just use my computer for web surfing than my iPhone.
     
  3. joshellis625 macrumors 6502

    joshellis625

    Joined:
    Feb 16, 2008
    Location:
    Baltimore
    #3
    try toggling airplane mode or taking out your SIM card and putting it back in.

    I can't think of anything else now that you said you already restored it.

    Good luck
     
  4. DPA macrumors 65816

    DPA

    #4
    I have used many other smartphones that are supposed to be great for searching the web and I rank the iPhone as number one. All the others I've had, I've only used as a last resort for searching the web and only used them if I absolutely needed to search the web.

    David
     

Share This Page