iPhone SD Card Adapter Fail - how to troubleshoot? Make it work?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Mattstkc, Jun 5, 2016.

  1. Mattstkc, Jun 5, 2016
    Last edited: Jun 5, 2016

    Mattstkc macrumors 6502a

    Mattstkc

    Joined:
    Dec 8, 2009
    Location:
    Chicago, IL
    #1
    iOS 9.3.2 on a 6S and have an SD Card Reader that I just bought (like say, an hour ago). Get home, take SDXC card from my Canon Rebel T5i, plug it in, see "Import" icon for like, 2 seconds, then poof, it's gone.

    Have restarted multiple times, won't work. SD card reads on every other device (Desktop, laptop w/USB Adapter).

    Per store.apple.com the adapter works for iPhone. Don't have an iPad to try there, so wtf is going on? Anyone know how to fix?


    Edit -- after force quitting Photos app I can relaunch and get "Import" to show up again but it disappears after. Could it be sheer # of photos that's crashing it? There's a few hundred.
     
  2. jahall05 macrumors regular

    Joined:
    Jul 30, 2013
    #2
    I would back the photos up on your computer, then I would format the SD card and then put the photos back on and try again.
     
  3. Mattstkc thread starter macrumors 6502a

    Mattstkc

    Joined:
    Dec 8, 2009
    Location:
    Chicago, IL
    #3
    I tried what you suggested with no success. I'm going to replicate the problem in store with a "Genius" or someone when I get the chance. Maybe try a different connector to see if the one I bought was defective. Thanks though.
     

Share This Page