iPhone SDK: Dashcode 2.0 Beta - Won't "run" a web app anymore!!

Discussion in 'iPhone Tips, Help and Troubleshooting' started by imaswitcheryeah, Mar 7, 2008.

  1. imaswitcheryeah macrumors regular

    imaswitcheryeah

    Joined:
    Jan 20, 2003
    Location:
    Brooklyn, NY
    #1
    Hello all,

    Has anyone been playing around with the new Dashcode to develop their web apps?

    Yesterday I was playing around, and hitting the Run button would launch the Aspen Simulator and let you try out the site locally before uploading to servers and such.

    Problem is, today I fired up Dashcode to play some more and the Run button doesn't work anymore!! The Run Log just sorta appears and disappears and nothing happens. I have tried completely restarting the computer, opening Xcode and seeing if the build+run function worked with the Aspen Sim (it did), and made sure the Aspen Sim was running while I tried hitting Run in Dashcode. Nothing!!

    I really don't want to have to re-install the entire SDK to resolve this, so if anyone else has experienced this and fixed it somehow I would be very grateful!

    Thanks,
    Dan
     
  2. miffy macrumors newbie

    Joined:
    Mar 8, 2008
    #2
    File a bug

    Maybe I'm wrong about the NDA but I don't think you can discuss publicly what's in Dashcode 2.0 since it is part of the iPhone SDK.

    So file a bug at <http://bugreport.apple.com>...and you know what, when I did these steps in the process of filing my bug, my problem was gone!

    1. Go to ~/Library/Preferences
    2. Look for com.apple.aspensimulator.plist (or something like that)
    3. Move that file to /tmp
    4. Attach that file the bug report (I forgot to to this step and now my bug is worthless)
    5. Relaunch Dashcode

    Please remember to file a report with the problematic plist file if indeed this solves your problem.

    HTH
     
  3. abijnk macrumors 68040

    abijnk

    Joined:
    Oct 15, 2007
    Location:
    Los Angeles, CA
    #3
    What NDA?? The SDK is publicly available for free.
     
  4. jrbj macrumors newbie

    Joined:
    Mar 13, 2008
    #4

    When you sign up to download the SDK, you have to click that you accept the NDA agreement.

    You have to click Accept on the same NDA agreement again when you actually install the SDK.
     

Share This Page