iPhone sdk firmware 3.1.1 support?

Discussion in 'iOS Programming' started by teckwiz, Sep 13, 2009.

  1. teckwiz macrumors newbie

    Joined:
    Mar 24, 2008
    #1
    Hi I am becoming interested in programming simple apps for my iTouch anyway recently updated to the latest firmware (3.1.1) however my xcode only seems to support 3.0 firmware what can I do so I can send my apps to my iTouch? I have noticed a file named "Firmware" with folders in it named all the previous firmwares eg "2.2.1" "3.0" and I was thinking I could just download one of those and place it in with the others
    Cheers
    Teckwiz
     
  2. robbieduncan Moderator emeritus

    robbieduncan

    Joined:
    Jul 24, 2002
    Location:
    London
    #2
    You will need to download the latest SDK from Apple
     
  3. wisesabre macrumors newbie

    Joined:
    Sep 14, 2009
    #3
    apple sux big time when updating something, they'll force you to update every thing just because u are developing iphone app.

    last time they automatically blocked my ipod firmware. I tried restoring it but failed. and update firmware wasnt available on our local apple store.

    (i was forced to used hacked firmware)

    after that i was told to update SDK. when I went to update sdk i was told to update my os.

    in short in this update ******** I had to update:mad:
    - iTunes
    - xcode
    - iphone sdk
    - iPod firmware
    - os
     
  4. dejo Moderator

    dejo

    Staff Member

    Joined:
    Sep 2, 2004
    Location:
    The Centennial State
    #4
    And yet there are developers still using older iPod firmwares and OSes. Apple even provides the lastest iPhone SDK for Leopard. So you may think you had to update but that really isn't the case.
     

Share This Page