iPhone SDK - Leopard

Discussion in 'iOS Programming' started by ethical, Apr 14, 2010.

  1. ethical macrumors 68000

    Joined:
    Dec 22, 2007
    #1
    Hi guys,

    Anyone know where I can get the SDK for Leopard, not Snow Leopard? The only links on the dev site seem to be for SL. I'm assuming this version won't install on my Leopard computer? Thanks

    p.s. Not talking about 4.0beta, just the standard version that Joe Bloggs can download.
     
  2. robbieduncan Moderator emeritus

    robbieduncan

    Joined:
    Jul 24, 2002
    Location:
    London
    #2
    Pretty much any SDK released since Snow Leopard was available has required it. I'm not sure what the last version of the SDK that supported Leopard was but it's pretty old now. Can you not upgrade to SL for some reason?
     
  3. ethical thread starter macrumors 68000

    Joined:
    Dec 22, 2007
    #3
    Ohh has it? I had it on my computer from about a year ago, then did a fresh reinstall a month ago, so came looking for it again...that would be why I haven't noticed :eek:

    No there's no reason I can't upgrade. Just haven't got around to it. I suppose when I did the fresh reinstall of Leopard would have been the prefect time :p

    Thanks anyway though :)
     
  4. robbieduncan Moderator emeritus

    robbieduncan

    Joined:
    Jul 24, 2002
    Location:
    London
    #4
    If you contact Apple they might be able to help you out. The problem is that it's technically copyright infringement for anywhere else to archive the older versions and Apple are not very good about leaving anything other than the current version and the next beta on their website.

    Edit: if you go to connect.apple.com and log in you can get older versions of XCode but I can't see any downloads for older iPhone SDKs. You might be able to use the last supported developer tools for 10.5 and the SDKs from the 3.2 iPhone SDK download together to get a working environment...
     

Share This Page