iphone sdk messed up

Discussion in 'iOS Programming' started by liptonlover, Oct 9, 2008.

  1. liptonlover macrumors 6502a

    Joined:
    Mar 13, 2008
    #1
    Ever since I got my touch and tried using it as a testing device, the iphone sdk has been acting weird. The first time I plugged it in, it showed up and said it was ready for testing. But after that, each time I try it gives me the following message.
    "Unable to locate a suitable developer disk image."
    "Re-install the iPhone SDK"
    I re-downloaded the sdk, and tried installing it. But the dmg wouldn't work. It said "codec error" when I tried unarchiving it. I tried repairing it, but it still wouldn't work. I downloaded and tried opening it AGAIN and it still wouldn't work. And, in desperation, I tried a third time. Still no luck. And just now I found yet another problem. Testing my interface using the iphone sim works fine, but I wanted to see how a custom button would look, so I tried building and running. But xcode gave me the following error.

    Checking Dependencies
    CodeSign error: no certificate found in the keychain for code signing identity 'iPhone Developer'

    The only variable here is trying to test with my touch. After that, it stopped. Does anyone have any help?
    Nate
     
  2. liptonlover thread starter macrumors 6502a

    Joined:
    Mar 13, 2008
    #2
    anyone? Please... I can't code while I have this problem :(

    Also... does anyone know how to apply custom graphics to an NSSlider? I'm talking about an iPhone one.
     
  3. tyr2 macrumors 6502a

    tyr2

    Joined:
    May 6, 2006
    Location:
    Leeds, UK
    #3
    Are you a paid up member of the iPhone Developers Program, i.e. did you pay you $99 and go through the certificate install process?

    You need to install the developer certificates that you create via the program portal before you can provision to a physical device. The only way to obtain these is to sign up for the full program.

    If you've paid then follow the steps given in the documentation on how to set this up, be very careful as it's easy to miss a step.

    Edit: And in answer to your question about a customized UISlider, there is a example in the 'UICatalog' demo app.
     
  4. liptonlover thread starter macrumors 6502a

    Joined:
    Mar 13, 2008
    #4
    No, I didn't. I have a free dev account, both for mac and iphone dev.

    So how do I un-sign up so I can code again?

    ok thanks.

    Nate



    edit: I went under project settings, and found a flag to set the testing device. Changing it to "iPhone Simulator fixed the problem when I tried building, but now it says the following when I try building. (In a modal window)

    "Unable to locate a suitable developer disk image."
    "Re-install the iPhone SDK" And it still didn't build. Thanks for your help so far.
    Nate




    edit edit: All problems finally solved. Thanks!
    Nate
     
  5. wesg macrumors regular

    wesg

    Joined:
    Jan 2, 2008
    Location:
    Toronto, ON
    #5
    What did you do to solve the developer disk problem? Xcode says that whenever I have my iPod connected. I'm restoring it now, hopefully that helps.
     

Share This Page