iPhone SDK / Simulator copies of all iPhone 2.0 Apps found / exchange, appstore etc

Discussion in 'Jailbreaks and iOS Hacks' started by ferrerpheonix, Mar 6, 2008.

  1. ferrerpheonix macrumors newbie

    Joined:
    Jul 3, 2006
    #1
    Hi there,

    I was playing with the simulator in the new SDK, found in

    /Developer/Platforms/AspenSimulator Platform/Developer/Applications/Aspen Simulator.app

    In there if you fire it up you get an iPhone with only Safari, Contacts and settings. Bit boring, so i started poking around trying to see if I could fire it up with all the apps.

    Inside:
    /Developer/Platforms/Aspen Platform/Developer/SDK's/Aspen.1.2.SDK/Applications
    There are all the 2.0 applications
    AppStore.app
    Calculator.app
    DemoApp.app
    Fieldtest.app
    Maps.app
    MobileAddressbook.app
    MobileCat.app
    MobileMail.app
    MobilePhone.app

    etc etc

    This struck me as interesting. I have yet to figure out how to run the simulator with all of these apps, if you know, please let me know. I'm digging through the docs now.

    However if you have an iPhone i wondered if you could just dump these apps onto it and get 2.0 functionality?

    Tristan

    Ps please, if you know how to run the simulator with these apps let me know. I can get it to run my apps through xcode but thats it.
     
  2. toxicbomber macrumors 6502a

    Joined:
    Jun 19, 2006
    #2
    Well I did manage to get the camera app working.... :D
     
  3. toxicbomber macrumors 6502a

    Joined:
    Jun 19, 2006
    #3
    Well I did manage to get the camera app working.... :D
     
  4. andyh2 macrumors member

    Joined:
    Dec 30, 2006
    #4
    This looks really interesting! I'm gonna experiment with this..
     
  5. NeoMayhem macrumors 6502a

    Joined:
    Aug 22, 2003
  6. El Carbonite macrumors regular

    Joined:
    Apr 1, 2006
    #6
    Anyone figure it out? I was very interested in this.
     
  7. antibact1 macrumors 6502

    Joined:
    Jun 1, 2006
    #7
    Just throwing these apps on your iPhone/iPod is not going to make it a 2.0. Some of these apps may work, some may not. They are all ARM binaries so they only way to know for sure is to SCP them over and give it a whirl.
     
  8. GirthP macrumors regular

    Joined:
    Oct 1, 2007
  9. ccb31789 macrumors newbie

    Joined:
    Mar 6, 2008
    #9
    That's very interesting. I'm not sure about running them in the simulator, but putting them on a real iPhone would be really easy. I made the mistake of upgrading my iPod to 1.1.4 before I realized 2.0 was required for all the good stuff, so now I'm about to go through the jailbreak process again. As soon as I do, I'll send those apps over and post the results.
     
  10. refulgentis macrumors regular

    Joined:
    May 14, 2006
    #10
    jailbroke my 1.1.4 iPhone, accessed it via FTP and uploaded AppStore. nothing changed at all. uploaded copies of every app then and selected for the old versions to be overwritten, and then things started going haywire. I got an SMS from my girlfriend at the same time, and I hit reply.

    The app opened up, but it seemed to be missing a bunch of resource files. There was no chat bubbles, and the top said something like APP_TITLE instead of the contact name, and the send button instead said something like SEND_TITLE_NAME or something, I can't really remember. I

    I went back to the home screen after that. Completely unresponsive, tapping did nothing. Reset the phone, and all of my apps were gone except bookmarks on the home screen.

    I was still able to receive SMS, but hitting close/reply did nothing. Displayed properly though, contact name and everything. Same for calls, displayed contact name and picture.

    Just restored my phone back to 1.1.4, since it seemed like I'd learn nothing else from it.
     
  11. macpoupou macrumors newbie

    Joined:
    Mar 7, 2008
    #11
    1.1.4 apps on Aspen Simulator (firmware 1.2)

    I try to move 1.1.4 apps in the emulator.
    It works but when you launch an app... I have this message in console.app:

    07/03/08 ven. 7 | 08:50:36 SpringBoard[1426] Unable to posix_spawn(), error launching /Developer/Platforms/AspenSimulator.platform/Developer/SDKs/AspenSimulator1.2.sdk/Applications/MobileTimer.app/MobileTimer error: No such file or directory

    07/03/08 ven. 7 | 08:50:36 SpringBoard[1426] Couldn't activate <SBApplication: 0x1a623f0> com.apple.mobiletimer activate: animated deactivate: killed
     

    Attached Files:

  12. ccb31789 macrumors newbie

    Joined:
    Mar 6, 2008
    #12
    Okay I've jailbroken my iPod to 1.1.4 again and tried the apps. They don't work. But I believe they can work with a few modifications. After looking at the package contents of the apps, I could see that the apps are actually only the binary files. A normal app would have resources such as images, string files, icons, and info files. If we could recreate working resources for these files, I think they could run.

    The binaries can't be run properly with the simulator. The binaries are of different types. The iPhone binaries are armv6 and the ones that the simulator use are i386. That would be why when transferring apps from a real iPhone, the icon in Mac OS X has the slashed circle icon over it. Anyone know of a method of figuring out what files an app is trying to access when run on an iPhone? If you could send the app to an iPhone then see which files it tries to load and put files in their place, the apps MIGHT work.

    So I just tried getting the Calculator application to run. After browsing through the strings in the binary, I've recreated sciRing.png, basicRing.png and the other file names I could find. After creating a bunch of files and sending it to my iPod, no luck, but at least we know the next update brings a decent scientific calculator. Also, I've noticed the 1.1.4 firmware includes all the necessary frameworks to run the new applications so that's a good sign. However, even after building my own apps, with build settings appropriate for a physical iPhone, the apps don't work. Go figure.
     
  13. macpoupou macrumors newbie

    Joined:
    Mar 7, 2008
    #13
    In fact, binaries in the iPhone simulator are Universal Binaries. You can't run native iPhone binaries.
     
  14. toxicbomber macrumors 6502a

    Joined:
    Jun 19, 2006
    #14
    Which was why I could get the camera app working. It was already a universal binary. :D Hey just drag and drop the mobileslideshow's info.plist file to the mobileslideshow in the aspen simulator and relaunch. Simple. :)
     
  15. macpoupou macrumors newbie

    Joined:
    Mar 7, 2008
    #15
    Lol yes it works ^^
    But Apple hasn't activated the iSight Camera in this case ^^
     
  16. Darkjenso macrumors regular

    Joined:
    Oct 27, 2007
    #16
    i managed to get the mail app into it, but it crashed the first time
     
  17. ferrerpheonix thread starter macrumors newbie

    Joined:
    Jul 3, 2006
    #17
    Thanks for all the interest!

    So if these Apps are not for the Simulator. (noone has them running right,) and they don't work on the iPhone, what are they for?

    Surely they must be for one of the two. I doubt the packaging of extraneous apps...
     
  18. ccb31789 macrumors newbie

    Joined:
    Mar 6, 2008
    #18
    I'm pretty sure they are for iPhone. I'm not sure why they were put in the SDK package or if they were even meant to be in there. They can probably run with some tweaking unless there's some way that the iPhone blocks new official SDK apps from being run on 1.1.4. I'm gonna experiment more with getting my own complete SDK apps to run on my 1.1.4. That seems like a more logical first step than trying to figure out how to package these binaries into apps and then getting them to run.
     
  19. ferrerpheonix thread starter macrumors newbie

    Joined:
    Jul 3, 2006
    #19
  20. ferrerpheonix thread starter macrumors newbie

    Joined:
    Jul 3, 2006
    #20
    I dont have an iPhone, but if I did, I would copy off Mobilemail.app and replace the executable with the ones here, creating a new one with new resources, upload it to the iPhone, and see what happened... *bang*, I'm guessing...
     
  21. Smith288 macrumors 6502a

    Smith288

    Joined:
    Feb 26, 2008
  22. ccb31789 macrumors newbie

    Joined:
    Mar 6, 2008
    #22
    Okay the reason my apps and the 2.0 apps are crashing is because the iPhone doesn't have the right frameworks. The iPhone doesn't have the QuartzCore framework at all, then when I copy that over from the Aspen SDK, I get undefined symbols from the Foundation framework referenced from QuartzCore. Copying that framework from the SDK screws things up even more and prevents some normal applications from working. :p

    Anyone else working on this? I don't really want to wait until June to be able to use the official SDK.
     

Share This Page