iPhone Silent Mode

Discussion in 'iPhone Tips, Help and Troubleshooting' started by xela24678, Jan 22, 2011.

  1. xela24678 macrumors regular

    Joined:
    Mar 1, 2010
    #1
    Hey guys, well i just found out that my iPhone won't go into silent mode. i pushed the silent button down until the orange sticker is showing but it doesn't vibrate or show the bell with the slash on the screen. I already restored it with back up and as a new phone but still. Any help?
     
  2. JamesMB macrumors 68000

    JamesMB

    Joined:
    Jan 2, 2011
    Location:
    Texas
    #2
    With the switch set to silent, what happens if you try to play a song through the speakers?
     
  3. xela24678 thread starter macrumors regular

    Joined:
    Mar 1, 2010
    #3
    it still plays, i called applecare and they said to restore it but i did. they said then to go to an apple retail store so they can take a look at it.
     
  4. JamesMB macrumors 68000

    JamesMB

    Joined:
    Jan 2, 2011
    Location:
    Texas
    #4
    Sounds like a hardware problem to me. The Apple store was gonna be my next suggestion. You probably already know this, but you can make an appointment so that you don't have to stand in line. Be sure you have a current backup so that you can restore the new phone with the backup.
     
  5. xela24678 thread starter macrumors regular

    Joined:
    Mar 1, 2010
    #5
    the thing that i'm scared about is that i jailbroke my iPhone and then i restored it. Thats when the problems started happening. i don't know if that is what caused it. If it did, Apple most likely won't help...:(
     
  6. xela24678 thread starter macrumors regular

    Joined:
    Mar 1, 2010
    #6
    Now it won't even display the bell picture on the screen. It seems like it's getting worse...
     
  7. JamesMB macrumors 68000

    JamesMB

    Joined:
    Jan 2, 2011
    Location:
    Texas
    #7
    I'm on my third generation of the iPhone and I have yet to JB one of them. I just flat don't want or need the hassle, as a trade off for the few extra features that I might get, or the different apps that I could run.
    It still sounds like a hardware problem to me. If you do a search using Mroogle, you will see that you aren't the only one that this has happened to.
    Since you managed to get it restored as new, Apple will never know that you had a JB running on it.
     
  8. xela24678 thread starter macrumors regular

    Joined:
    Mar 1, 2010
    #8
    Thanks, by the way I didn't change any setting on my iPhone 4 while I had the jailbreak. I didn't even get winterboard. I just did it for installous. Kinda sad I know. But whatever, thanks:eek:
     
  9. JamesMB macrumors 68000

    JamesMB

    Joined:
    Jan 2, 2011
    Location:
    Texas
    #9
    Let me know how it goes with Apple...I bet that you are gonna get a new phone.
     
  10. xela24678 thread starter macrumors regular

    Joined:
    Mar 1, 2010
    #10
    I hope so. At least a repair. By the way, I found out today that when I squeeze the front and back screens near the silent switch, it goes to silent mode! I don't know if there's something loose inside of my phone bu Apple will tell me :D
     
  11. xela24678 thread starter macrumors regular

    Joined:
    Mar 1, 2010
    #11
    Went Apple an got a replacement. Thanks for the help
     
  12. JamesMB macrumors 68000

    JamesMB

    Joined:
    Jan 2, 2011
    Location:
    Texas
    #12
    That's great! :D
     

Share This Page