iPhone Simulator locks up immediately upon Build / Run

Discussion in 'iOS Programming' started by 40developer7, Apr 17, 2010.

  1. 40developer7 macrumors newbie

    Joined:
    Apr 17, 2010
    #1
    I'm having a problem getting my **MacBook** set up to build **iPhone** **apps** in **xCode**. The iPhone **Simulator locks up** and shows the "spinning circle" busy icon.

    I've tried everything I can think of, including

    - resetting the simulator
    - tried all of the different hardware options in the Simulator (5 or 6)
    - tried the two debug build choices in xCode.
    - uninstalling the SDK and completely reinstalling
    - tried creating xCode projects on Desktop and in \Developer...

    I downloaded the SDK "**xcode_3.2.2**_and_iphone_**sdk_3.2**_final"

    I'm just upgraded from Leopard to **Snow Leopard (10.6.3)**. I've run all the software updates. **xCode** version says **3.2.2** (1650)

    If it matters, my MacBook is 3-4 years old, 13 inch, dual 2.16 ghz intel cores, 2 gig RAM. I've never had a single problem with it.

    I would be so grateful if anyone can help me

    thanks so much,
     
  2. skunkworker macrumors regular

    Joined:
    Sep 9, 2007
    #2
    Does it work to build for an actual device? And which application locks up? Xcode or iPhone simulator. Use the activity monitor to see if a program stops responding. Also you don't need the "**something**" everywhere.
     
  3. 40developer7 thread starter macrumors newbie

    Joined:
    Apr 17, 2010
    #3
    Thanks so much for the help

    I just finished installing the 4.0 SDK. (on someone else's recommendation). I made a new windows-based iPhone app (HelloWorld) and tried a build/run (Simulator-4.0 | Debug)

    Same exact behavior... The simulator appears and the rainbow spinning progress wheel just keeps going and going

    I took a sample from the process ("not responding...") - I'm attaching it to this in case that helps

    thanks again, i really appreciate it.

    thanks again
     

    Attached Files:

  4. 40developer7 thread starter macrumors newbie

    Joined:
    Apr 17, 2010
    #4
    I haven't had any luck loading a test App onto my iPhone. I even tried zipping the folder, changing extension to .ipa... I don't have the $99 developer "membership" at this point

    I get "... is not a valid application"

    I installed the new SDK 4 beta. Although I checked off all the SDK's on the install, i only see 4.0.

    So I'm wondering if it won't load because my iPhone is not 4.0 OS

    i may just install the last SDK again and work from there. The 4.0 beta doesn't seem to have helped at all

    Thanks again!
     
  5. dcbr1000 macrumors newbie

    Joined:
    Jun 1, 2010
    #5
    Ok I had the same problem and tried to contact apple with no luck there. here's what I did to solve my problem, I was going to to format my drive and reinstall OSX snow leopard but i got to thinking that it was something with the upgrade from older versions of OSX so I decided to just install snow leopard on a portable drive first and see what happen and it worked and now the simulator does not freeze anymore. so what I'm saying is try a reformat and install of snow leopard fresh or like I did install onto a external drive if you don't want to do that,which is what worked for me. hope this help alot of people cause I been searching all over the net for a solution. also I have the same macbook as you have so the specs were the same.
     
  6. dejo Moderator

    dejo

    Staff Member

    Joined:
    Sep 2, 2004
    Location:
    The Centennial State
    #6
    Without jailbreaking, you must be part of the paid developer program in order to deploy your app to a device.
     
  7. bredell macrumors regular

    Joined:
    Mar 30, 2008
    Location:
    Uppsala, Sweden
    #7
    You also seem to have a problem with your pointers.
     
  8. PatrickCocoa macrumors 6502a

    Joined:
    Dec 2, 2008
    #8
    NSBlogPost *myQuestion = [[NSBlogPost alloc] initWithRandomPunctuation];
     

Share This Page