iPhone SMTP problems with MobileMe

Discussion in 'iPhone' started by nicksolly, Jan 28, 2011.

  1. nicksolly macrumors newbie

    nicksolly

    Joined:
    Jul 15, 2009
    Location:
    London, Uk
    #1
    I am having problems when sending email from my MobileMe account on my iPhone when trying to use an alternative SMTP Server.

    I have a MobileMe account that I want to send email from a @mydomain smtp server, I have turned off the @me.com server, and set it to send out through the @mydomain. The emails sent are still showing my @me.com address as the sender.

    I have tried a number of work arounds including sending through a gmail account set up to send through the @mydomain, however the address still shown is @me.com. This set up works absolutely fine in my mac Mail app. My current solution is not ideal, as I have set up the @mydomain account as a separate account running, so I receive duplicate emails.

    I have this set up to create a consolidated email account. I have a number of different accounts feeding into my @me.com account via gmail. This provides me a level of protection from spam and the level of control I need on my accounts.

    If anyone can offer any advice as to why my MobileMe account on my iPhone always shows my @me.com address despite othe smtp servers being used I would be very grateful.

    I am running iOS 4.2 on an iPhone 4.
     
  2. LapsangSouchong, Jan 28, 2011
    Last edited: Jan 28, 2011

    LapsangSouchong macrumors 65816

    LapsangSouchong

    Joined:
    Jul 15, 2010
    Location:
    the burrows
    #2
    You have two options: On your phone you have to have your @mydomain as an account, and then select it as the "from" address each time you compose or reply to an email. Lame, I know. It's my single biggest beef with the iphone.

    Or, as an unusual work around:You can also set up mobile me as not a mobile me account, if that makes sense, ie not letting the iphone set it up for you. You set it up as a mail only account, with the "from" field being your @domain account. the smtp being smtp@yourdomain.... So I have TWO ME accounts. One handling contacts and calendar, one doing your mail. Tell your @yourdomain to forward, not mirror to ME.
    Looks like this:
    [​IMG]
     

Share This Page