iPhone sometimes won't send email

Discussion in 'iPhone Tips, Help and Troubleshooting' started by crc0427, Jul 18, 2008.

  1. crc0427 macrumors newbie

    Joined:
    Jul 18, 2008
    #1
    I am having an issue with my new iPhone 3G 16GB. it's on the Rogers network in Toronto.

    Sometimes when I try to send an email it just sits there saying connecting... but it never connects. I have to power off the phone and turn it back on for email to start working again.

    and the worst part is, I lose whatever email I was trying to send. It doesn't go into any outbox, sent items, or drafts.

    Is anyone else haivng thing issue?
     
  2. rgingalls macrumors newbie

    Joined:
    Aug 27, 2008
    #2
    I am having same problem on AT&T

    I am having this problem, too. My iPhone is NOT a 3G and I have had this problem for some time. It is much worse since the new software update. I am primarily in Oklahoma, but I travel quite a bit.

    I can sit in one place, send an email successfully, and then send another email unsuccessfully just a few minutes later. It is very, very frustrating. If I cannot trust the iPhone with my mail, it is pretty worthless to me.

    It will also get to a point where it will not receive email without rebooting. The "Connecting..." message never disappears.
     
  3. Mhaddy macrumors 6502

    Mhaddy

    Joined:
    Oct 26, 2005
    Location:
    Canada
    #3
    You're not alone - this was discussed in another thread as well. I think it's less of a carrier issue than it is a software issue.
     

Share This Page