iPhone stuck, can't upgrade to final 3.0 release.

Discussion in 'iPhone' started by HyperSnake, Jun 19, 2009.

  1. HyperSnake macrumors member

    Joined:
    Jan 5, 2009
    Location:
    Switzerland
    #1
    I'm an Apple iPhone Developer and my iPhone was running iPhone OS 3.0 BETA 5(couldn't be bothered to upgrade to GM seed). Now yesterday when I tried to upgrade to the newly released final version through iTunes, it said I was already running the latest version of the OS (which I'm not, Im running a beta). I also tried to restore my phone but it said: "There was a problem downloading the iPhone software for the iPhone (name of my iphone). The requested source was not found." Now today, my iPhone is locked. I have tried to do all the same as well as the steps on this site:http://support.apple.com/kb/HT1923 (except for the iphone reinstall and hcange of USB connection steps). Now I really dont know what to do. Can anybody help me? Basically all I need is the final 3.0 firmware to be downloaded to my computer.

    This is sorta urgent so I'd appreciate fast answers

    Yours,
    BEN.
     
  2. scaredpoet macrumors 604

    scaredpoet

    Joined:
    Apr 6, 2007
    #2
  3. Gavin Hall macrumors newbie

    Joined:
    Jun 22, 2009
    #3
    I had exactly the same problem this morning and this seems to work. The final 3.0 OS is now downloading through iTunes.
     

Share This Page