iPhone stuck in -1 error

Discussion in 'iPhone Tips, Help and Troubleshooting' started by zaphoe, Jan 16, 2013.

  1. zaphoe macrumors newbie

    Joined:
    Jan 16, 2013
    #1
    Hey guys

    I've got a iphone 4 and I can't use it anymore cause Itunes after restoring process says 'can't restore device, -1 error'. I've been trying many many things, tinyumbrella, limer1, redsnow, restore with older ios, nothing works.

    I'd better let you know this iphone crashed during the io6 update process.
    The one thing that gets me worried is an -1 error is often associated with a hardware error. I gotta tell you there is no sim card in my iphone anymore, since it it crashed I cancelled my phone subscription


    thanks for taking the time to read me. :)
     
  2. RgnCjn87 macrumors newbie

    Joined:
    Jan 16, 2013
    #2
    I've actually had this same exact problem. My phone crashed one day while trying to connect to bluetooth in my car. I fought for 2 days trying to restore/reinstall firmware on the phone, kept getting -1 error. The issue ended up being with the power button on my phone. If you have experience opening the phone, you know there are three connectors to the motherboard of the phone. I believe one is for the power button and the other 2 for the lcd. Try unplugging them one at a time. Once you unplug the one that is causing issues the phone should boot up on its own. Your issue may not be with the power button, but its worth a shot. I guess the issue could also be with other hardware failing, such as the camera.
     
  3. zaphoe thread starter macrumors newbie

    Joined:
    Jan 16, 2013
    #3
    ha thank you very much for taking the time to answer me, I'll give that a try. Some people say it might be the antenna touching and making a short circuit. The one thing that worries me is applecare told me I could not send the iphone for a fix if it's been opened before. As my waranty period is over, I gotta pay 140£ to get it repaired :( maybe I'm better of bying the iphone 5 right away, but I'm not sure it's worthy
     
  4. zaphoe thread starter macrumors newbie

    Joined:
    Jan 16, 2013
    #4
    Ok it gets better

    all I had to do was built a custom ipsw with snowfreeze without using the iboot option, and then jailbreak with redsnow. now i could restore my old backup with itunes, it's almost perfect except the device can't find the network, i've bought a new sim, but it says 'search' all the time and can't find the 3G and phone network.

    anyone has an idea were that comes from ?

    thanks again
     
  5. iPhone Bits macrumors newbie

    Joined:
    Jan 20, 2013
    #5
    What firmware are you running?
     
  6. zaphoe thread starter macrumors newbie

    Joined:
    Jan 16, 2013
    #6
    io6
     
  7. daudi macrumors member

    Joined:
    Jan 1, 2012
    #7
    try this guide here. this might help u. if not then feel free to commment below.
     

Share This Page