Iphone stuck in loop even after Restore (NOT jailbroken)

Discussion in 'iPhone Tips, Help and Troubleshooting' started by JuiceeciuJ, May 6, 2010.

  1. JuiceeciuJ macrumors newbie

    Joined:
    May 6, 2010
    #1
    So my iphone seems to be stuck in a reboot loop it'll display the apply logo, then the apple and a loading circle and then it shuts off briefly and starts the entire loop again. It keeps doing it until the battery dies or until I shut it off. I've put the phone into DFU mode and restored three times and I still have the same issue? Any ideas on what else I could do to fix it?
     
  2. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #2
    How did it happen in the first place? Do you get any error messages?

    You probably have some hardware failure, but I'm not sure. Are you setting up as new?
     
  3. iFixYouri macrumors member

    Joined:
    Mar 20, 2010
    #3
    Could be hardware related...ever have the glass changed or any other hardware? Does the phone have any water damage?

    We had 2 phones in the shop today with the same problem, turned out to be something with the mid-frame(frame that holds the glass, LCD, home button, ear speaker, proximity sensor). Swapped out the entire frame and phones started right up.
     
  4. JuiceeciuJ thread starter macrumors newbie

    Joined:
    May 6, 2010
    #4
    Actually it did have some water damage about a two weeks ago. I let it dry in a bag of rice for 4 days. Then it started back up and worked perfectly for about a week until I started getting a message saying that the device connected was not compatible with my phone. Problem was there was no device connected. So Then I sprayed the dock connector area with contact cleaner. After doing so there was a little bit of residue left on the inside of the screen so I took the phone apart to clean it up. Once I put it back together I started having this problem.

    So, how much is it going to cost to get a new frame? How easy would it be to install it on my own?

    Thanks for your help guys!
     
  5. Makanmata macrumors member

    Joined:
    Jun 21, 2009
    #5
    I'm reading this with interest because I am currently having the same problem with a jailbroken 3GS. My phone has never been dropped or damaged in any way. Yesterday I locked it during a meeting, and it froze shortly after I unlocked it a few hours later. None of the buttons would respond, so I decided to try the hard reset of holding the power and start buttons together for 10 seconds. It turned the phone off, but it will not reboot.

    Instead, when the phone is plugged in or reset, I get the Apple logo, followed about 2-3 minutes later by the time circle which freezes as soon as it appears. The phone stays this way for 10 minutes or so, until it resets itself with a black screen, followed by a red bar battery symbol, and then the Apple logo followed by the frozen time circle.

    I have tried all of the standard reset strategies (pressing both buttons, tethering while the computer reboots, holding the start button while it is plugged in, all with and without the sim installed) and nothing has gotten it beyond the loop. I will now try the DFU move, but I'm not optimistic.

    I have an Apple store nearby, but I am reluctant to take it there due to the Jailbreak (although I don't know how they would know given the state that the phone is in). I would also hate to have them replace the phone with a replacement that has the new bootrom that can't be jailbroken (or have they now managed to jailbreak these too?).

    Thanks for the help.
     
  6. JuiceeciuJ thread starter macrumors newbie

    Joined:
    May 6, 2010
    #6
    Hey Ifix,

    Thanks for the suggestions. I did take apart the phone and i wasn't sure if the small connector was re-inserted properly. Do you think that may be causing the problem?
     
  7. iFixYouri macrumors member

    Joined:
    Mar 20, 2010
    #7
    It could be. Water damage can make the phone act funky. As corrosion begins, you may see a lot of problems over time. All corrosion needs to be removed from the iPhone or features can/will begin to fail or act erratically. We would suggest having the iPhone run through a full water damage repair process in order to ensure full functionality.
     
  8. iFixYouri macrumors member

    Joined:
    Mar 20, 2010
    #8
    Since it is jailbroken - DFU Mode - Full Restore - Should take care of it ;-)
     
  9. Makanmata macrumors member

    Joined:
    Jun 21, 2009
    #9
    Thanks. That did work, in that the phone is now operating properly and fully restored. Unfortunately, I once again have a non-jailbroken and locked phone with the automatic upgrade to 3.1.3 which I had been trying so hard to avoid. Hopefully, there is -- or soon will be -- a way to unlock this firmware version.

    Thanks again.
     
  10. JuiceeciuJ thread starter macrumors newbie

    Joined:
    May 6, 2010
    #10
    Update

    Ok, so I took the phone apart and removed the three cables that attach the lcd/glass assembly to the main body of the phone. I took care to replace cable 3 (the small one) properly. After that the phone booted up just fine and has been booting up fine for the past couple days. Thanks for the help.
     
  11. iFixYouri macrumors member

    Joined:
    Mar 20, 2010
    #11
    Not a problem. There is jailbreak available for 3.1.3. Functions quick. Search for spirit.
     

Share This Page