Iphone stuck in recovery when trying to update

Discussion in 'iPhone Tips, Help and Troubleshooting' started by WyattTheWarrior, Jul 10, 2008.

  1. WyattTheWarrior macrumors newbie

    Joined:
    Jul 10, 2008
    #1
    So I found out that iTunes 7.7 was available so I updated my software. I also found out that you can download iphone 2.0 software on the internet so my iphone was still jailbroken so I decided to restore it before I attempted to download the 2.0 software. After I restored it itunes synced all of my songs and such back to my iphone and it wasnt jailbroken any longer. Then I tried to update my phone to the 2.0 software I had just downloaded from the internet and when my phone was restoring and updating it just stopped. So I put the phone into recovery mode and plugged it back into my computer and now it says it cannot restore because of unknown error 20. Now im screwed because its stuck in recovery mode and i cant do anything with it. Any help please?
     
  2. SubaRusso macrumors newbie

    Joined:
    Jul 10, 2008
    #2
    error 20

    this has happened to me too and i can not find out how to get it out of restore mode...i knew i shouldnt have tried this....if anyone has any way of fixing this please help!
     
  3. veritas327 macrumors newbie

    Joined:
    Jul 10, 2008
    #3
    Just wanted to say that I am also stuck in this situation. Any help would be great.
     
  4. veritas327 macrumors newbie

    Joined:
    Jul 10, 2008
    #4
    Ok so I have gotten somewhere but I am not sure how.

    Background:
    I have a 16gb unlocked, jailbroken iPhone that I have been using a tmobile sim card in. Today I upgraded to iTunes 7.7, downloaded the 2.0 ipsw, Shift+Check For Updates, and had a 2.0 iPhone after about 10 minutes. Here is where I think the problem occurred: I opened ZiPhone and tried to do the SIM unlock. It got stuck in recovery mode and I could not restore it (error 20). I tried the shift+restore to 2.0 and shift+restore to 1.1.4 both of which provided me errors. I restarted my computer, tried unsuccessfully to downgrade iTunes and reinstalled iTunes 7.7. All of the same errors. I tried all of the things listed above multiple time and still errors.

    I tried shift+restore to 2.0 and all of a sudden it started to restore to 2.0. I wish I could tell you the last couple of steps I took before it worked but I can't remember the order. I was trying all of the things listed above multiple times and in different orders.

    So when it is done restoring, I am sure I will still have the SIM problem but at least it won't be stuck in recovery mode.

    Keep trying the things I did above and maybe you will be fortunate like me. Best of luck! I will keep you updated if I figure anything out.

    Update: Yep, now iTunes is telling me I don't have a compatible SIM card which is expected. I can either try ZiPhone again (and risk getting stuck again) or try and shift+restore/update to 1.1.4 and jailbreak
     
  5. WyattTheWarrior thread starter macrumors newbie

    Joined:
    Jul 10, 2008
    #5
    ill give it a try i called apple and they said that the iphone 2.0 software i downloaded probably messed with the software and hopefully the update tomorrow will fix it. But I think that they are wrong but if this doesnt work then i give up and ill wait until tomorrow
     
  6. veritas327 macrumors newbie

    Joined:
    Jul 10, 2008
    #6
    I have been able to restore to 2.0 multiple times now. I have resolved to using a five year old nokia and waiting until a SIM unlock tool comes out (hopefully soon).
     
  7. zenmark macrumors newbie

    Joined:
    Apr 21, 2006
  8. zenmark macrumors newbie

    Joined:
    Apr 21, 2006
    #8
    I'm having similar troubles, I tried to update and it said "cannot be updated because of an unknown error (5) " so then it did the connect to itunes screen and i took it out and connected it again, itunes said it was in recovery mode, and then it did a restore on it, now it's restored but then once it said it'd restored and was going to come back up, it crashed as it was coming up (something my phone has actually been doing a fair bit recently, i was going to take it to the store to get that fixed anyways)
    Anyways, reset it, it came back and finished restoring, and then I tried again... no dice again. And again...
    So I'm gonna bet I'm not getting anywhere near my iPhoon 2.0 goodness...
     
  9. justmattyg macrumors newbie

    Joined:
    Aug 18, 2006
    #9
    Hey guys, I'm new to the forums, and hate a first post like this but I'm in between a rock and a hard place.

    I downloaded the 2.0 firmware this morning before work, started installing, it locked up and I had to force quit, it did not finish and apparently locked my phone into recovery mode.

    So now when I try to goto iTunes to restore it to factory settings it gives me the message of "The iphone "iphone" could not be restored. An unknown error occured 1604". I called apple support and they were like you having problems? then its probably because of the server overload. I don't think it has anything to do with the server overload, I'm not trying to install or download 2.0. I just want factory settings, when I click restore it attempts to install 1.1.6 firmware and ends unsuccessfully with the error message of (1604).

    I'm at a loss here, I don't know what else to do. I downloaded the iPhone1,1_2.0_5A347_Restore.ipsw 2.0 firmware and option clicked restore in itunes. Again same error message.

    I just want this iBrick back to factory settings, its been stuck at the connect to itunes icon on my screen all day. Is there any third party software to get this bad boy running again?
     
  10. justmattyg macrumors newbie

    Joined:
    Aug 18, 2006
    #10
    how can i restore my iphone with out itunes!?
     

    Attached Files:

  11. detroitpimp421 macrumors newbie

    Joined:
    Mar 4, 2008
    #11
    i have a 1st gen iPhone and today i tried to upgrade to the 2.0 software.
    i plugged my iphone into my comp and opened itunes, i then dowloaded the software and now itunes says....itunes has detected a iPhone in recovery mode and you must restore before you can use it with itunes. so then i hit restore and press restore and update. then it extracts the software and wen it finishes with that says....The iPhone could not be restored. An unknown error occurred (20).

    please help
    i cant get it
    thanks
     
  12. dwd3885 macrumors 68020

    Joined:
    Dec 10, 2004
    #12

    This works.

    Hold shift +restore and then when the confirmation comes up, hold shift + restore again. Then it will download the 2.0 software. Then repeat the process and it will restore the phone to 2.0
     
  13. justmattyg macrumors newbie

    Joined:
    Aug 18, 2006
    #13
    negatory. no luck what so ever.

    I was able to go up several teirs of apple support and finally got to an iphone specialist with a brain that wasn't reading out of a knowledge base.

    He had me trash the itunes application, the mobile device .kext, the itunes pkg files from the originial install, and even the new/old firmware. Reinstalled all of that still no luck. We tried different usb slots, cables, computers, versions you name it we tried it.

    It pretty much narrowed it down to the version of the firmware I downloaded early this morning completely effed my device.

    Solution: sending iphone in for repair/replacement, cya in 7 days iphone.

    If anyone else has a better way or suggestion please don't hesitate to share.

    -sad iphone owner
     
  14. zombitronic macrumors 65816

    zombitronic

    Joined:
    Feb 9, 2007
    #14
    I've got a similar problem.

    Background:
    Powermac G4 MDD, Leopard
    Original iPhone, never unlocked, never jailbroken. I've run into problems on almost every update, so I tried to be extra cautious.

    I plugged my phone in and did a sync. It added a contact and updated a song that I've changed the album art on. Everything was fine.
    I checked for and found the 2.0 update and made sure to download only. After that was okay, I started the update. It was taking awhile but everything went okay through the backup process. Before the restore, the phone reset and iTunes began preparing the software. This took awhile, but eventually went into "Restoring iPhone software..." The loading bar didn't move for about 15 minutes and then the system crashed. This happened to me on a previous update.

    I reset and iTunes automatically started at startup and notified me that there's an iPhone connected that needs to be restored. It went through the same preparing and restoring procedure with no success, but this this time it ended with an error telling me the iPhone could not be restored.

    I'm trying one more time, but right now the installer has been at "Restoring iPhone software..." with no progress on the bar for 30 minutes. The phone shows the Apple logo and the spinning loading wheel.
     
  15. zombitronic macrumors 65816

    zombitronic

    Joined:
    Feb 9, 2007
    #15
    Fixed!?!

    As previously posted, I was having big problems with my iPhone 2.0 update...wouldn't restore. After that last attempt failed, I tried again with no success and finally turned off the phone prematurely and unplugged it from this computer.

    I tried to restore from an old Power Book G4 where it downloaded the 2.0 software and attempted to install it. I left, and when I came back I found that it got me to the point that I could make emergency calls, but I still got an error message on that Power Book saying that the computer couldn't find the iPhone.

    I unplugged it and brought it back to this Power Mac where I tried to restore again. The installer told me it was restoring the backup, and the progress bar was moving. The phone also said it was attempting to activate, but failed after awhile because it said it couldn't get a signal. A few minutes later, the phone restarted and gave me a message that my phone had been activated. SUCCESS!! Everything had be restored, except for the music. The best part is that 2.0 is now on the phone!

    The only problem was, iTunes had quit with the progress bar still on Restoring iPhone backup. I just force quit it and I'm going to attempt to re-sync my music and install my apps.

    I really hope this helps someone.
     

Share This Page