Iphone stuck on Apple logo and loading circle.

06awjudd

macrumors newbie
Original poster
Aug 3, 2012
6
0
Hi all!

Bought a faulty second hand iPhone :eek:. It came stuck in recovery mode, and while trying to restore to IOS 5.1.1 I kept getting error 1604.

I decided to restore to the current firmware (not sure if it's jailbroken or not) by downloading IOS 4.2.1 (unjailbroken). I thought this had worked as I got no error, but now it's stuck on the apple logo with the swirling loading circle :confused:

Any idea what I can do, or what is causing it?
Or is it just a hardware issue:( ?

Thanks sooo much for any help whatsoever.
 

ipsychedelic

macrumors 6502a
Mar 8, 2012
633
22
If your phone is stuck on the loading apple of death, then your best shot is to try and get it on DFU mode with redsn0w and then jailbreak it.
If you could restore firmware via iTunes and it only fails at the end, chances are the firmware was in fact, restored perfectly, but for some reason (I can't recall) it won't boot.

I had this happen to me on a friend's iPhone 3G and I used redsn0w and a combination of hard resets (hold power+home) and trying to get into DFU until redsn0w could finally recognize it and jailbroke it just fine.
 

Sohailt00

macrumors newbie
Aug 5, 2012
9
0
Singapore
Just do this

Press the HOME and LOCK button for about 15 seconds then let go the lock button and keep holding the HOME button it should go out of it!
 

06awjudd

macrumors newbie
Original poster
Aug 3, 2012
6
0
Okay I'll try the jailbreak - good advice.

Sohailt00 - I know how to enter DFU mode ;) , but thanks for the advice.
 

06awjudd

macrumors newbie
Original poster
Aug 3, 2012
6
0
Okay I jailbroke the iPhone on 4.1 with Redsn0w , and it went through the process fine, but then got stuck on the apple logo again afterwards.

I then tried to boot tethered and it got stuck on the pineapple logo :mad: .

Any other fix ideas?

Could it be a hardware issue?
If so any diagnostics I could do?

EDIT: Fixed it! Turns out a semi connected cable #3 was the culprit, so happy!
 
Last edited:

Neepo.woo

macrumors newbie
Oct 19, 2012
1
0
Okay I jailbroke the iPhone on 4.1 with Redsn0w , and it went through the process fine, but then got stuck on the apple logo again afterwards.

I then tried to boot tethered and it got stuck on the pineapple logo :mad: .

Any other fix ideas?

Could it be a hardware issue?
If so any diagnostics I could do?

EDIT: Fixed it! Turns out a semi connected cable #3 was the culprit, so happy!
how did you actually fix it?im having the same problem now..please reply asap.