iPhone suddenly unable to connect to wi-fi

Discussion in 'iPhone Tips, Help and Troubleshooting' started by mestevie, Apr 6, 2009.

  1. mestevie macrumors newbie

    Joined:
    Jan 20, 2008
    #1
    Having a problem with my iPhone all of a sudden not being able to connect to wi-fi. I have had 2.2.1 installed from day 1, so its not a recent change.

    My setup at home is a Telstra Wireless Gateway (Netgear), one airport express connected to my beyonwiz PVR, one airport express connected to my Mac Pro, and a macbook. All these devices are on the wireless network and the iPhone happily played with all of these on wi-fi until Sunday morning.

    First of all there is a very weak signal. It will basically see the network interimittently, and when it does see it, will not connect. The message is 'unable to join xxxx network'. Note that it has been happily working on wifi for over 6 months.

    Recent changes to my network was the addition of the second airport express. However, the phone has been working for two weeks solid since I did this.

    Last app installed was skype - but again - happily played until Sunday.

    After doing some googling I have tried the following troubleshooting actions:

    1) Turned phone off and on. Asked the phone to 'forget' my network. No change
    2) Restored iPhone from backup and re-installed 2.2.1 - No change
    2) Reset all network settings on the phone - No change
    3) Took all protection off of the wireless modem/router ie WEP psk - No change
    4) Changed the ip range on the modem - no change
    5) released and renewed DHCP lease that the iphone had established - no change
    6) Tried to enter a static ip address based on what the other machines on the network were using - cannot conclusively say I did this correctly as I was not sure what to put in the 'domain' field, but still - no change

    Today I tried to get the phone to connect to another network that I know has worked in the past. Same symptoms - weak signal and unable to connect.

    I fear the wi-fi in the phone has gone belly up. My only hope is that many, many people on the web have experienced very similar problems - so I am hoping its some sort of networking settings issue.

    Any other things I should try?

    Cheers
    Steve
     
  2. SFMACBOOK macrumors newbie

    Joined:
    Feb 8, 2009
    Location:
    Bay Area SF
    #2
    Help

    I too have the same problem and tried the same things except the ip thing since i also have an IPod touch which connects just fine and someone else has a iphone aswell and they too can connect any help would be great.:confused:
     

Share This Page