iphone sync and server connection issues

Discussion in 'iPhone' started by junker, Dec 28, 2007.

  1. junker macrumors 6502

    junker

    Joined:
    Jul 3, 2006
    Location:
    An obtuse corner of the Triangle
    #1
    2 problems.

    One - tonight I hooked up my (valid account) iphone to sync with itunes...it's been syncing for about a half an hour. It's never done that before! I had it synced up earlier - about 4 hours ago- no problem... once finished, it displayed: "Ok to disconnect."

    In the interim, I took it with me to dinner...I did nothing with it... no change, pics or calls after the last sync.

    I force quit itunes and restarted itunes (with the iphone plugged in) saw the iphone, it started the sync... wouldn't stop. So, I then tried to restore thru itunes - it wouldn't cancel the sync to restore.

    Finally I force quit itunes - left it closed (closed iphoto also) and did the manual (hold down the sleep and home button for about 20 seconds) then it restored and validated. Then it installed the latest backup of my iphone settings, music and pics.

    Now the sync is going....18 minutes. GRRR!

    I specifically didn't do a single hack or anything - jsut to play nice and allow for this version 1 product to iron out wrinkles and weak spots....now this!

    Second issue. I will have 5 bars service...and can't connect to the server in Safari (on the iphone) What gives?

    If anyone has any insight, I would greatly appreciate it!
     
  2. telefono macrumors 6502

    telefono

    Joined:
    Dec 17, 2007
    #2
    Same here :( Sync now takes about half an hour.
    This problem started yesterday, I am new to the iPhone and iMac and everything went well with setting up the Mac and the iPhone since last month. Hope someone knows what is going on as I don't know how to fix the problem.
    I shut down the mac and iphone, restarted again and it doesn't help.
     
  3. walnuts macrumors 6502

    Joined:
    Nov 8, 2007
    Location:
    Brooklyn, NY
    #3
    I had the exact same problem this morning. I started a sync and iTunes froze in the middle of the sync. Upon closer inspection, the iphone was not perfectly connected (may have become ajar midsync?). Anyway, after that, all syncs hung iTunes, and even requesting a restore wouldn't work (just like you, the restore couldn't cancel the sync. I had to restart itunes again and put the phone in and prevent it from syncing, before I was able to restore.

    I did one sync, and loading the music and videos over again took forever. I had to leave it home or be late for work.
     
  4. walnuts macrumors 6502

    Joined:
    Nov 8, 2007
    Location:
    Brooklyn, NY
    #4
    Edge isn't available in all areas, when you are on the phone, etc. Do you have the "E" indicator or at least the empty blue box (GPRS web)? Finally, you could get the "can't connect to server" message if the website is no good.
     
  5. walnuts macrumors 6502

    Joined:
    Nov 8, 2007
    Location:
    Brooklyn, NY
    #5
    My sync just took 9 minutes with no music or data exchange. While it is shorter than your syncs, it is far longer than usual.

    Then I tried replacing the data on my phone with a fresh copy from the computer (see pic):

    That has solved problems for me in the past. No luck here; its still taking forever!! Did I screw my phone up somehow? I can't wait this long for every sync!
     

    Attached Files:

  6. junker thread starter macrumors 6502

    junker

    Joined:
    Jul 3, 2006
    Location:
    An obtuse corner of the Triangle
    #6
    "Edge isn't available in all areas, when you are on the phone, etc. Do you have the "E" indicator or at least the empty blue box (GPRS web)? "
    --Not sure... but I'm sitting in a starbucks and I used to get web service there... but none today.


    "Finally, you could get the "can't connect to server" message if the website is no good."
    --Haha - funny.... it was Macrumors and Slashdot... read into that what you will ;-)

    BTW - I thought a new fangled deal with starbucks and apple was that their itunes integration to the currently playing songs....

    And for a long-sync update - it finally finished about 25 minutes into it.... granted this time it reloaded all my stuff as well... one thing that seemed to get it going was when I clicked on to my music folder...then it started to sync calenders, music etc.

    offtopic: how do I multi quote other people (as above)? I lost my formatting that usually goes with quoting.
     
  7. skunk macrumors G4

    skunk

    Joined:
    Jun 29, 2002
    Location:
    Republic of Ukistan
    #7
    My syncing, too, has begun to take forever. What the hell is going on??? :confused:
     
  8. holycow macrumors newbie

    Joined:
    May 28, 2006
    #8
    It's also happening to me. Argh... have to go on a trip tomorrow.

    Could it have been the recent security update? I installed it and then this started happening.
     
  9. skunk macrumors G4

    skunk

    Joined:
    Jun 29, 2002
    Location:
    Republic of Ukistan
    #9
    No, it isn't that, as I have not installed it. I've spoken to Apple, but of course they "haven't heard about this issue". :rolleyes:

    EDIT: I've just restored the iTunes software on the phone and everything is working OK.
     
  10. nsheikh80 macrumors regular

    nsheikh80

    Joined:
    May 2, 2005
    Location:
    London, England
    #10
    I have been experiencing this problem for the last few days. I was about to restore my hacked iPhone and then I found the solution!

    Connect your iPhone to iTunes.

    Open up Activity Monitor and quit the process labelled “MDCrashReportToo”. Voila, your iPhone should start syncing immediately.

    Trouble is that you will have to quit the process everytime you want to sync.

    All credit goes to iPhone Atlas, their aricle has some alternative solutions if the above does not work: http://www.iphoneatlas.com/2007/12/28/fixing-the-iphone-sync-freeze/

     
  11. skunk macrumors G4

    skunk

    Joined:
    Jun 29, 2002
    Location:
    Republic of Ukistan
    #11
    Since restoring, my phone is working perfectly, so unless you've hacked your phone, I would recommend this as a far more hassle-free solution.
     
  12. junker thread starter macrumors 6502

    junker

    Joined:
    Jul 3, 2006
    Location:
    An obtuse corner of the Triangle
    #12
    Morning...well I left it plugged in all night to charge. Woke up, read the forum and suggestions (thanks - I restored it last night) unplugged it and plugged it back in to sync at 7:46 a.m. and as of 7:58 a.m. the sync is still going on... apparently same issue remains.

    The restore did not work for me.

    I tried starting the online music (as I had thought in an earlier post).... and no change, still syncing.

    Crap.

    And I leave, in a few hours, for a trip for 5 days. I hope this wont somehow grow into something else.

    Not sure if this is related, but over xmas I went to the in-laws house for a few days and recharged nightly (with their itunes) through their Dell XPS PC system. Of course, I did NOT sync with anything they had - I actually downloaded itunes specifically for this purpose.
     
  13. junker thread starter macrumors 6502

    junker

    Joined:
    Jul 3, 2006
    Location:
    An obtuse corner of the Triangle
    #13
    ok, I killed the MDcrashreporter tool as someone previously suggested.

    It worked.

    Just to see that be the "workaround" solution again I unplugged then plugged it in and started a new sync (8:02).

    By 8:10 the sync was still syncing. So, I did the MDcrashreporter tool kill again. It worked - itunes started actually syncing up and then it finally quit.

    I really can't believe I have to manually kill a process to make this work!!! I can't understand it... a little disappointed. Leopard's been a bit of a buzzkill, so I hoped the iphone would compensate for the Leo aggrevation.
     
  14. skunk macrumors G4

    skunk

    Joined:
    Jun 29, 2002
    Location:
    Republic of Ukistan
  15. nsheikh80 macrumors regular

    nsheikh80

    Joined:
    May 2, 2005
    Location:
    London, England
    #15
    Early reports suggest that it is a problem on Apple's side. Apparently the MDCrash tries to talk to a server or something, don't quot me on that though.

    I'm sure Apple will fix it soon.

    I know its not ideal but at least we have a workaround. A non-syncing iPhone reduces its usefulness to me quite significantly.
     
  16. boiee macrumors member

    Joined:
    Oct 22, 2005
    #16
    I quit the application "MDCrash.." under activity monitor and this fixed the problem immediately. Thanks! Although, I hope Apple fixes this problem ASAP so I don't have to keep doing this. Boo Apple. Haha.
     
  17. Driller macrumors newbie

    Driller

    Joined:
    Jul 11, 2007
    #17
    Disabling my internet connection solved the problem for me. I just blocked all internet activity with ZA while I synced. Then unblocked again. A pain but it works.
     
  18. Manj27 macrumors member

    Joined:
    Jul 10, 2007
    Location:
    London
    #18
    To add to this thread - i too experienced syncing problems over the past day or two - it was taking forever to sync one album (left running for 30mins at one time). Each attempt finally resulted in force wuit of iTunes - i will tr killing the process reffered in this thread, hopefully it will work and hopefully Apple will release a fix to this issue.
     
  19. soLoredd macrumors 6502a

    Joined:
    Mar 12, 2007
    Location:
    California
    #19
    I've been experiencing this for 2 days now and actually the day I got my iPhone on the 2nd sync it happened. Almost took it back. But, I've read a few Apple discussions and so many others are having the problem.

    What I've found that works...forget killing the MDCrash process...is to just disable internet as Driller said and it works fine. My sync takes around 15 seconds - if no music or movies are being synced.

    Apple needs to address this, though, and fast because having to take these side steps is ridiculous. Usually they are on the ball so I don't know where the ball is being dropped right now. So, everyone fill out some Apple Feedback and let's get this taken care of.
     
  20. telefono macrumors 6502

    telefono

    Joined:
    Dec 17, 2007
    #20
    Thanks Mate.......worked for me too :D
     
  21. walnuts macrumors 6502

    Joined:
    Nov 8, 2007
    Location:
    Brooklyn, NY
    #21
    I wonder- it is strange- my iPhone had been fine since 1.1.2 so there's been no change with the phone recently. The security update sounds like a good possibility.

    So, to help confirm this, is anyone having this problem with a windows computer?
     
  22. levitynyc macrumors 65816

    Joined:
    Aug 19, 2006
    #22
    Some people on the apple.com forums are having issues with Vista.
     
  23. Silverbird0000 macrumors 6502a

    Joined:
    Sep 19, 2006
    Location:
    Fort Myers, FL
    #23
    I think it seems like everyone has been having this problem start in the last few days. My 1.1.2 iPhone has been working perfectly since I got it a month ago. Now, 2 days ago it started not syncing unless I quit the MDcrashreport. My friends iPhone also started not syncing 2 days ago. It has to definitely be something on Apple's side. And as the above post said, maybe it is the most recent security update. I installed it about 4-5 days ago and had not synced since then until 2 days ago and my sync did not work.
     
  24. walnuts macrumors 6502

    Joined:
    Nov 8, 2007
    Location:
    Brooklyn, NY
    #24
    Is there an apple forum on this issue? Could you post a link?
     
  25. junker thread starter macrumors 6502

    junker

    Joined:
    Jul 3, 2006
    Location:
    An obtuse corner of the Triangle
    #25
    this will be short - I am in another state with only the iPhone for Internet access... I don't think its the security update- I didn't download it - I had read too many things negative, so I held off.

    We've got to think of another cause - my bet is against apple here.

    Another issue! Problably half of my pictures icons are blank in my iPhone. If I click the blank space where a pic should be, it will show on larger size - but no preview icon.... Grrrr
     

Share This Page