iPhone syncing apps with wrong PC?

Discussion in 'iPhone' started by Wolfpup, Feb 11, 2014.

  1. Wolfpup macrumors 68030

    Joined:
    Sep 7, 2006
    #1
    iOS and iPods only seem to sync right with a single PC...I've recently switched to a new one I'm wanting to sync with, and everything syncs with the new one (not WELL, given how terrible iOS is with podcasts now, but...) except apps still sync with the old one.

    Anyone know how to fix that? It seems like in iTunes most or all of the categories have an option to say whether you're syncing or not, EXCEPT the 'apps' category, which doesn't have any settings I can see except "automatically install new apps", which I keep unchecked.
     
  2. Wolfpup thread starter macrumors 68030

    Joined:
    Sep 7, 2006
    #2
    Weirdly I couldn't find this information anywhere online, but I did stumble across a simple but non-intuitive fix.

    You can actually view which computer iOS is syncing what with in the "wifi sync" section of the device's settings (which is actually a "sync" section which applies for ANY type of syncing, despite saying wifi), which can help you confirm what's syncing where. In my case the new computer was syncing most everything, but my old one was still listed as syncing 'apps'.

    The fix was to check the "automatically install new apps" box in iTunes, then sync, then uncheck that box, then sync again. THAT finally associated the new PC with the iPhone for 'apps', and was reflected on the "wifi sync" section on the iPhone.

    Super glad I figured that out as I was about ready to do a clean install of my iPhone's OS, which of course would require setting stuff up again.

    I'm annoyed with how all this syncing has gotten generally...like that should have an explicit option to associate it with a new PC, and the various media syncing options should either be selectable separately, or explicitly group together the ones that actually sync together, otherwise it's just memory and guesswork...

    But oh well, at least I found a fix!
     

Share This Page