[iPhone Tethering] Will This Work?

Discussion in 'Jailbreaks and iOS Hacks' started by Shadow%20Mac, Feb 16, 2010.

  1. Shadow%20Mac macrumors 6502

    Joined:
    Dec 28, 2007
    Location:
    California
    #1
    I'm trying to tether with my iPhone 3GS 3.1.2, and I want to know whether this process will work.

    1.) Download and install Blackra1n on my Mac.
    2.) Hit make it rain (thus installing the Blackra1n installer on the phone).
    3.) Install sn0w from Blackra1n.
    4.) Remove Blackra1n from the phone.
    5.) install this profile from:

    http://m.peacefulinsanity.com/Tether.mobileconfig

    I'm fairly certain this will work (my friend has done it). My question is, will a iTunes restore undo it?

    Thanks in Advance.
     
  2. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #2
    Yes, any time you restore your phone you lose your jailbreak and all of your jailbreak apps and customizations. Incidentally, if you have no need of the unlock but only wish to tether, I would strongly suggest using eagos' CommCenter patch instead of blacksn0w. Blacksn0w can cause many problems, including periodic loss of WiFi.
     
  3. Samuriajackon macrumors 6502

    Samuriajackon

    Joined:
    Feb 9, 2009
    #3
    I just googled the EAGOS' COMMCCENTER PATCH but it says 3.1.2 for iPhone software, what bad sorta stuff happens if i try on a 3.1.3? OR! how do i get to 3.1.2 safely? I don't wanna do anything that won't be wiped out in iTunes restore, but I don't wanna wait for AT&T tethering.
     
  4. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #4
    You are on a jailbroken 3.1.3?
     
  5. Samuriajackon macrumors 6502

    Samuriajackon

    Joined:
    Feb 9, 2009
    #5
    No i'm afraid not, i've only used the Behn hack to use tether and that when away when I Updated my iPhone last...
    :D
     
  6. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #6
    Since iPhone OS 3.1 it has not been possible to tether unless your phone is jailbroken.
     
  7. Samuriajackon macrumors 6502

    Samuriajackon

    Joined:
    Feb 9, 2009
    #7
    thanks.
     
  8. FoxMcWeezer macrumors regular

    Joined:
    Nov 4, 2009
    #8
    Are you sure? I saw a video that this guy went to http://help.benm.at and downloaded the configuration for his carrier and was able to tether. But that video was months old.
     
  9. Plutonius macrumors 603

    Plutonius

    Joined:
    Feb 22, 2003
    Location:
    New Hampshire
    #9
    On AT+T. Outside the US, people are able to tether depending on their network.
     
  10. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #10
    Precisely, it was months old. Installing the BenM tethering hack on a non-jailbroken phone is no longer possible since 3.1 because Apple began to require signatures for mobileconfig files. In order to enable tethering using a hacked configuration file, you must patch CommCenter to remove the signature check...and that can only be done on a jailbroken phone.

    Samuriajackon said that he was on AT&T, though, so I don't think it particularly relevant what people on other carriers are able to do.
     
  11. Shadow%20Mac thread starter macrumors 6502

    Joined:
    Dec 28, 2007
    Location:
    California
    #11
    Answers and More Questions:

    1.) help.benm.at has found a new solution for 3.1.x, however, it seems to have problems for people in the US on AT&T.

    2.) My OCD commands me to tell you all that its BenM not BenN. Sorry :)

    Questions:

    Now that you guys explained the process, can someone help me downgrade from 3.1.3 to 3.1.2?
     
  12. pcs are junk macrumors 65816

    Joined:
    Sep 28, 2009
    #12
    I noticed in your signature you are using a 3GS. If you did not click the Make My Life Easier button in Cydia before Apple stopped signing firmware, you cannot downgrade whatsoever. I don't think you have been Jailbroken before, and therefore you wouldn't have been able to use Cydia. According to your first post, you were clueless about Jailbreaking.
     

Share This Page