Iphone turns on and turns off at apple logo

Discussion in 'iPhone Tips, Help and Troubleshooting' started by gunnerz14l, May 6, 2010.

  1. gunnerz14l macrumors newbie

    Joined:
    May 6, 2010
    #1
    Hi, i have a JB iPhone 3G 3.1.2 OS. Everything has been fine until now. I had SBRotator on and all of a sudden it started to go really slow and in the end not respond. So i turned my iphone off by holding the power and home buttons and now whenever I turn it on it stays on the apple logo screen for about 10 seconds and then switches itself off. I've never had a problem with SBRotator before. What can I do to get it working again? Any help is greatly appreciated. Thanks.
     
  2. Patryk R32 macrumors newbie

    Joined:
    Apr 22, 2010
    #2
    Same thing started happening to me last night. i thought it was a battery issue, but it wasn't.

    i had to restore the phone.


    i am also on 3.1.2 OS

    just restore it with 3.1.2 software and blackra1n it again
     
  3. burningstarfive macrumors newbie

    Joined:
    May 7, 2010
    #4
    so that is what happened to my iPhone:

    big question: my home button doesn't work, what now?

    I can't get it into usb mode and it doesn't show up on windows/mac ???
     
  4. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #5
    Without the home button, you're stuck with going to Apple and getting an OOW replacement for $199 (hopefully they can't tell your JB), or you need to get it repaired by one of the fixit shops.
     

Share This Page