iPhone UK and Voicemail

Discussion in 'iPhone' started by martymcr, Nov 23, 2007.

  1. martymcr macrumors member

    Joined:
    Jan 12, 2005
    Location:
    Cheshire, UK
    #1
    Has anyone got problems with Visual Voicemail?

    I've now been asked to set a password and set a greeting twice. This must have worked because when I ring my number from another line I get my personalised message.

    I discovered last night that I wasn't being advised of new messages, and have left myself 2 messages this morning (23/11/07) with no alerts on the iPhone to advise me.

    Is there a way to 'call' voicemail to check like on other networks/phones?

    My phone is a bog standard UK model on O2, not unlocked/hacked etc.
     
  2. alFR macrumors 68020

    Joined:
    Aug 10, 2006
    #2
    I think you can dial 901 to access voicemail - check on O2's site. You'll need to put in your password.
     
  3. Nicolasdec macrumors 65816

    Nicolasdec

    Joined:
    Dec 7, 2006
    Location:
    São Paulo
    #3
    Visual voice mail isnt working so well for me ether. Do you need to be conected via EDGE to get VV?
     
  4. CD3660 macrumors 68040

    CD3660

    Joined:
    Jun 6, 2007
    Location:
    Cheshire, United Kingdom.
    #4
    You can indeed access your voice mail directly by dialing 901. Just tried it and didn't have to enter a pin code/password.
     
  5. Seamaster macrumors 6502a

    Seamaster

    Joined:
    Feb 24, 2003
    #5
    Have you transferred another number across using a PAC code?
     
  6. thworple macrumors 6502

    thworple

    Joined:
    Oct 20, 2005
    Location:
    Sussex, England
    #6
    I'm having problems as well. Its not notifying me of new messages that I've been leaving myself on my office phone as a test, and when I dial 901, I get the lovely automated lady on the other end of the line, telling me I have no new messages!

    Rang o2 twice yesterday. Firstly was advised to dial 1760 from my iPhone, which disables voicemail, then 1750 which reactivates it. Switch off the iPhone afterwards for a minute or two and then it should work. It didn't.

    Rang them back, and was put through to someone in their Tech dept. who did a reset of all my mailbox settings from her end, and she rang and left me a new voice mail message, and lo and behold it worked - visual voice mail retrieval - the lot.

    Then this morning it doesn't work again - same rubbish about there being no new messages even when I ring 901. Not great.
     
  7. rushmere macrumors 6502

    rushmere

    Joined:
    Jul 28, 2006
    Location:
    Auckland
    #7
    Exactly the same problem here.

    Deactivating and then reactivating voicemail didn't help.

    o2 have now told me to switch it off for at least 20 minutes and see if it then works. It sounds unlikely to me, but I'll give it a try......
     
  8. thworple macrumors 6502

    thworple

    Joined:
    Oct 20, 2005
    Location:
    Sussex, England
    #8
    Ok. Rang o2 again and I've got a solution that works. They suggested going into settings - general - reset and then resetting network settings. This should restart your iPhone.

    This alone didn't work, but dialling 1760 to switch off voicemail then 1750 to switch it on again did. I now can call myself on the office phone and leave a message, and it can be retrieved on my iPhone via visual voicemail.
     
  9. rushmere macrumors 6502

    rushmere

    Joined:
    Jul 28, 2006
    Location:
    Auckland
    #9
    Thanks for posting this - it worked for me too!
     
  10. thworple macrumors 6502

    thworple

    Joined:
    Oct 20, 2005
    Location:
    Sussex, England
    #10
    No probs. As a footnote to this, after getting it to work via this method, I decided to add a custom greeting message on my voice-mail, and as soon as I changed it, the bloody thing stopped work again.

    Went through the solution I posted above again, and all is now working fine again.

    Bottom line is, that its one to remember, as fiddling with any of your voice-mail settings seems to require this level of resetting.
     
  11. skeen macrumors 6502

    Joined:
    Jul 12, 2007
    Location:
    London, England
    #11
    Great, this worked for me. :)
     
  12. sparkyms macrumors 65816

    Joined:
    Feb 22, 2007
    Location:
    Southampton UK
    #12
    my voicemail shows up when it gets left, but a lot of the time visual voicemail is unavailable, which is pretty rubbish.

    I love the idea and when its available it works great, but its hardly revolutionary when its not available all the time..
     
  13. alFR macrumors 68020

    Joined:
    Aug 10, 2006
    #13
    Ah, OK - maybe that's just from other mobiles or landlines then.
     
  14. alFR macrumors 68020

    Joined:
    Aug 10, 2006
    #14
    Hmm, mine isn't working either: had a voice message left earlier that didn't show up. dialling 901 got it for me though. have tried the above fix but now I get "voicemail unavailable - unable to initiate connection" every time I go to the voicemail screen. As a few people seem to be having difficulty I'm wondering if this is either a network issue (i.e. general cockup at O2's end, maybe overloaded system) or if this is a problem due to having ported my number across from Orange. I even waited to set it up until my number had ported as i knew I might have to set it up again. :(

    Has everyone else having problems ported their number, or is anyone using a totally new one and still not getting it to work?
     
  15. CD3660 macrumors 68040

    CD3660

    Joined:
    Jun 6, 2007
    Location:
    Cheshire, United Kingdom.
    #15
    I had this message for the first time this afternoon. OK now though.

    Incidentally, I have a ported number which transferred last monday, but this is the only problem that I have had with Visual Voicemail, and it was very temporary.

    Edit: I just checked my post count, and this is 901! Quite a coincidence. Hopefully a good omen.
     
  16. alFR macrumors 68020

    Joined:
    Aug 10, 2006
    #16
    mine has randomly started working now. :) hopefully it will continue to do so. How is everyone else getting on?
     
  17. herodian macrumors member

    Joined:
    Feb 14, 2007
    Location:
    sitting down with warm legs
    #17
    02 rang me yesterday to say that some people had been saying that the VV wasn't working properly for people who ported their number. we got it working (i think) but i was quite amazed that they rang me about it, not the other way round..

    nice one 02.
     
  18. Bernie Steak macrumors newbie

    Joined:
    Nov 9, 2007
    #18
    This explains a call I had today asking if my phone was OK, and if voicemail was all working as it should be (it is). I also ported from Vodafone. Thought it was nice to be called like that though, even if it has been trouble free.
     
  19. alFR macrumors 68020

    Joined:
    Aug 10, 2006
    #19
    Just a quick heads-up: I thought my voicemail had stopped working again today, but actually it was just taking a while (like 10min) for the messages to show up there after they'd been left. Spoke to O2 and apparently it's a known issue at the moment and they're working on it.
     
  20. CD3660 macrumors 68040

    CD3660

    Joined:
    Jun 6, 2007
    Location:
    Cheshire, United Kingdom.
    #20
    I thought that there was a bit of a delay. Let's hope that they sort it out.
     

Share This Page