iPhone Unlock Issues... am I the only one?

Discussion in 'iPhone' started by pdpfilms, Sep 15, 2007.

  1. pdpfilms macrumors 68020

    pdpfilms

    Joined:
    Jun 29, 2004
    Location:
    Vermontana
    #1
    So I've been using the GUI iUnlock for a few days now, and it's been pretty unpredictable for me. Though it seems most people are getting it to work 100% all the time...

    The software unlocks my iPhone perfectly right after a full restore. But as soon as I turn off and restart the iPhone, it's as if the software has been reversed. I get the message that there is an incorrect SIM, and I can't place calls or send texts. The Carrier setting in the General Settings menu still exists, but all options are greyed out.

    The worst part is I've restored 5 times now, and reinstalled iUnlock 5 times, and it does the same thing EVERY time. Can everyone else restart their unlocked iPhone with no issues?
     
  2. vega07 macrumors 65816

    Joined:
    Aug 7, 2006
    #2
    perhaps you should try the harder/manual way of unlocking. I haven't tried the GUI but I can tell you that mine works 100% of the time after the manual method of unlocking.
     
  3. pdpfilms thread starter macrumors 68020

    pdpfilms

    Joined:
    Jun 29, 2004
    Location:
    Vermontana
    #3
    Thanks to Compile 'em All, it's fixed. The issue was a bad activation, as I used the default AT&T SIM, not my T-Mobile. I hadn't heard that this was a necessary step, but it clearly is.
     

Share This Page